Click or drag to resize

IGH_Attributes Methods

The IGH_Attributes type exposes the following members.

Methods
  NameDescription
Public methodAppendToAttributeTree
Recursively append these attributes and all child attributes to the attribute list.
Public methodExpireLayout
Expires the entire layout of the attributes. When overridden, implementer must place a call to the base class ExpireLayout().
Public methodInvalidateCanvas
If the mouse location should cause a canvas invalidation then return true. You only need to override this function if you draw objects that are dependant on cursor positions outside the bounds of the attributes.
Public methodIsMenuRegion
Determines whether a point is available for context menu popups. By default, IsMenuRegion calls IsPickRegion(PointF).
Public methodIsPickRegion(PointF)
Determines whether a point is within the pickable region for this object. By default, any point inside the Bounds is treated as pickable.
Public methodIsPickRegion(RectangleF, GH_PickBox)
Determines whether a rectangle is a valid pick region for this object. By default, the picking rectangle is intersected with the Bounds rectangle.
Public methodNewInstanceGuid
Generate a new instance GUID for the owner object.
Public methodNewInstanceGuid(Guid)
Generate a new instance GUID for the owner object. Do not use this overload unless you're > 1.95m and called David.
Public methodPerformLayout
Recompute the layout for these attributes. This function is automatically called during Drawing operations, so you typically don't have to.
Public methodRenderToCanvas
Render these attributes into a Canvas control.
Top
See Also