Click or drag to resize

GH_Canvas Methods

The GH_Canvas type exposes the following members.

Methods
  NameDescription
Public methodAddTagArtist
Add a Tag Artist instance to this canvas.
Public methodAddValidator
Add a new drop validator to the canvas.
Public methodAutoSaveDocument
Public methodCanvasOldSchoolMenu
Public methodCreateMRUPanels
Create new MRU panels. This function only does something if there is no document loaded in the canvas.
Public methodCreatePreview
Render this canvas to a thumbnail preview.
Public methodDestroyMRUPanels
Destroy any MRU panels that might be in existence.
Protected methodDispose (Overrides ControlDispose(Boolean).)
Public methodGenerateHiResImage
Generate a collection of hi-res images of the document.
Public methodGenerateHiResImageTile
Generate a single tile in a Hi-Res image export.
Public methodGetCanvasScreenBuffer
Get a bitmap that resembles the current state of the canvas.
Public methodGetGraphicsObject
Gets a graphics object for this control. You are not allowed to draw with this object, use it only for visibility testing and such. If you're inside a canvas update, use the Graphics() property instead. You must dispose of the Graphics object returned by this method or resources will be leaked.
Public methodHideMRUPanels
Hide all existing MRU panels by sliding them out of view.
Public methodInstantiateNewObject(Guid, PointF, Boolean)
Public methodInstantiateNewObject(Guid, String, PointF, Boolean)
Public methodNavigate
Perform a single navigation step.
Protected methodOnPaint (Overrides ControlOnPaint(PaintEventArgs).)
Protected methodOnPaintBackground (Overrides ControlOnPaintBackground(PaintEventArgs).)
Public methodOnViewportChanged
Ensure the canvas and document viewport data are synchronised and raises the ViewportChanged event.
Public methodReevaluateMarkovSuggestions
Public methodRemoveAllTagArtists
Remove all IGH_TagArtists from this canvas. Do not use this method unless you want to screw over everyone else.
Public methodRemoveTagArtist(Guid)
Remove all IGH_TagArtists from this canvas that match a certain ID.
Public methodRemoveTagArtist(IGH_TagArtist)
Remove a specific tag artist from this canvas. If the instance occurs multiple times in the TagArtist list, all instances will be removed.
Public methodRemoveValidator
Remove a drop validator from the canvas.
Public methodScheduleRegen
Schedule a regen to occur after the specified number of milliseconds have elapsed. If a Regen is called in this time frame, the schedule will be cleared. Only a single schedule can be active at any time, so any call to ScheduleRegen will clear existing schedules.
Public methodSetSmartTextRenderingHint
When this method is called during a redraw, the TextRenderingHint of the associated graphics object will be set to either GH_CrispText or GH_SmoothText depending on zoom level.
Public methodShowComponentSearchBox
Display the component Search dialog at the current mouse location. The dialog cannot be shown if ModifiersEnabled=False.
Public methodShowComponentSearchBox(Point)
Display the component Search dialog at the given coordinate. The dialog cannot be shown if ModifiersEnabled=False.
Public methodShowMRUPanels
Show any hidden MRU panels by sliding them back into view.
Public methodShowNavigationPane
Displays the quick-navigation popup pane at the cursor.
Public methodShowSearchDialog
Display the Find dialog. If a Find dialog is already active for this canvas, nothing will happen.
Public methodStartAutoPan
Start the auto-panning timer.
Public methodStopAutoPan
Stop the auto-panning timer.
Public methodUpdateDocumentPreview
Call this method to update the preview thumbnail for the currently loaded document. If no document is currently loaded, nothing will happen.
Top
Extension Methods
  NameDescription
Public Extension MethodToEto (Defined by EtoExtensions.)
Top
See Also