Click or drag to resize

GH_ComponentServerTypeHints Property

Gets a list of all IGH_TypeHint types in all loaded assemblies.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public IList<Type> TypeHints { get; }

Property Value

Type: IListType

[Missing <value> documentation for "P:Grasshopper.Kernel.GH_ComponentServer.TypeHints"]

Return Value

Type: IListType
A list of System.Type containing all classes that implement IGH_TypeHint.
See Also