Click or drag to resize

GH_ColourCube Properties

The GH_ColourCube type exposes the following members.

Properties
  NameDescription
Public propertyBackFace
Gets a graphics path describing the back face of the cube. Caller is responsible for disposing of this path instance.
Public propertyBottomFace
Gets a graphics path describing the bottom face of the cube. Caller is responsible for disposing of this path instance.
Public propertyC0
Gets the first point in the corner point list.
Public propertyC1
Gets the second point in the corner point list.
Public propertyC2
Gets the third point in the corner point list.
Public propertyC3
Gets the fourth point in the corner point list.
Public propertyC4
Gets the fifth point in the corner point list.
Public propertyC5
Gets the sixth point in the corner point list.
Public propertyC6
Gets the seventh point in the corner point list.
Public propertyC7
Gets the eighth point in the corner point list.
Public propertyGrip
Gets the rectangle that describes the slice grip.
Public propertyLeftFace
Gets a graphics path describing the left face of the cube. Caller is responsible for disposing of this path instance.
Public propertyPivot
Gets the point that describes the center of the pivot on the slice.
Public propertyS0
Gets the first point in the shadow point list. This point is coincident with C0.
Public propertyS1
Gets the second point in the shadow point list. This is the corner of the drop-shadow on the bottom face.
Public propertyS2
Gets the third point in the shadow point list. This point is the kink of the drop-shadow on the edge connecting C2 and C3.
Public propertyS3
Gets the fourth point in the shadow point list. This point is coincident with C7.
Public propertyS4
Gets the fifth point in the shadow point list. This point is coincident with C4.
Public propertyShadow
Gets a graphics path describing the outline of the drop shadow. Caller is responsible for disposing of this path instance.
Public propertySilhouette
Gets a graphics path describing the silhouette of the cube. Caller is responsible for disposing of this path instance.
Public propertySlice
Gets the rectangle that describes the cutting slide through the current colour space.
Top
See Also