Click or drag to resize

GH_ColourCube Class

Maintains a collection of graphical shapes and coordinates that specify important features of the Colour Space Cube graphics.
Inheritance Hierarchy
SystemObject
  Grasshopper.GUI.BaseGH_ColourCube

Namespace:  Grasshopper.GUI.Base
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_ColourCube

The GH_ColourCube type exposes the following members.

Constructors
  NameDescription
Public methodGH_ColourCube
Create a new instance of this class.
Top
Properties
  NameDescription
Public propertyBackFace
Gets a graphics path describing the back face of the cube. Caller is responsible for disposing of this path instance.
Public propertyBottomFace
Gets a graphics path describing the bottom face of the cube. Caller is responsible for disposing of this path instance.
Public propertyC0
Gets the first point in the corner point list.
Public propertyC1
Gets the second point in the corner point list.
Public propertyC2
Gets the third point in the corner point list.
Public propertyC3
Gets the fourth point in the corner point list.
Public propertyC4
Gets the fifth point in the corner point list.
Public propertyC5
Gets the sixth point in the corner point list.
Public propertyC6
Gets the seventh point in the corner point list.
Public propertyC7
Gets the eighth point in the corner point list.
Public propertyGrip
Gets the rectangle that describes the slice grip.
Public propertyLeftFace
Gets a graphics path describing the left face of the cube. Caller is responsible for disposing of this path instance.
Public propertyPivot
Gets the point that describes the center of the pivot on the slice.
Public propertyS0
Gets the first point in the shadow point list. This point is coincident with C0.
Public propertyS1
Gets the second point in the shadow point list. This is the corner of the drop-shadow on the bottom face.
Public propertyS2
Gets the third point in the shadow point list. This point is the kink of the drop-shadow on the edge connecting C2 and C3.
Public propertyS3
Gets the fourth point in the shadow point list. This point is coincident with C7.
Public propertyS4
Gets the fifth point in the shadow point list. This point is coincident with C4.
Public propertyShadow
Gets a graphics path describing the outline of the drop shadow. Caller is responsible for disposing of this path instance.
Public propertySilhouette
Gets a graphics path describing the silhouette of the cube. Caller is responsible for disposing of this path instance.
Public propertySlice
Gets the rectangle that describes the cutting slide through the current colour space.
Top
Methods
  NameDescription
Public methodAverage(Color, Color)
Compute the average of two colours.
Public methodAverage(Color, Color, Color, Color)
Compute the average of four colours.
Public methodBlend
Inteprolate between two colours.
Public methodColorAtRail
Get the color at a position along the depth rail.
Public methodColorAtSlice
Get the color at a position on the slice.
Public methodRenderAll
Call all render methods in the correct order.
Public methodRenderBackEdges
Render the edges of the back face creases.
Public methodRenderBackFaces
Render the fills of the backfaces.
Public methodRenderDropShadow
Render the drop shadow of the cube.
Public methodRenderEdgeShadows
Render the edge shadows of the cube due to GI.
Public methodRenderForeEdges
Render the edges of the fore face creases.
Public methodRenderGrip
Render the slice grip.
Public methodRenderPivot
Render the colour pivot on the current slice.
Public methodRenderSilhouetteEdges
Render the edges of the cube silhouettes.
Public methodRenderSlice
Render the square slice with colour gradients.
Public methodRenderSliceDropShadow
Render the drop shadow onto the slice.
Public methodRenderSliceEdgeShadows
Render the edge shadows of the slice due to GI.
Public methodRenderSliceSilhouetteEdges
Render the silhouette edges of the slice.
Top
See Also