Click or drag to resize

GH_DocumentObject Properties

The GH_DocumentObject type exposes the following members.

Properties
  NameDescription
Public propertyAttributes
Gets or sets the attributes that are associated with this object. Only set custom attributes if you know what you are doing.
Public propertyComponentGuid
Returns a consistent ID for this object type. Every object must supply a unique and unchanging ID that is used to identify objects of the same type.
Public propertyExposure
Gets the exposure of this object in the Graphical User Interface. The default is to expose everywhere.
Protected propertyIcon
Override this function to supply a custom icon (24x24 pixels). The result of this property is cached, so don't worry if icon retrieval is not very fast.
Public propertyIcon_24x24
The icon associated with this object.
Public propertyIcon_24x24_Locked
The greyscale icon of this object.
Public propertyIconDisplayMode
Gets the current display mode of the object.
Public propertyObsolete
Gets whether this object is obsolete. Default implementation returns true if the class name contains the string "OBSOLETE" or if this class has been decorated with the ObsoleteAttribute. You are free to override this if you want, but I suggest adding the ObsoleteAttribute instead.
Top
See Also