Click or drag to resize

GH_InstanceDescription Class

Base implementation of IGH_InstanceDescription. Consider deriving from this class rather than implementing IGH_InstanceDescription from scratch.
Inheritance Hierarchy

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_InstanceDescription : IGH_InstanceDescription

The GH_InstanceDescription type exposes the following members.

Properties
  NameDescription
Public propertyCategory
Gets or sets the Category in which this object belongs. If HasCategory() returns false, this field has no meaning.
Public propertyDescription
Gets or sets the description of the object. This field typically remains fixed during the lifetime of an object.
Public propertyHasCategory
Gets whether or not the Category field has been set.
Public propertyHasSubCategory
Gets whether or not the SubCategory field has been set.
Public propertyInstanceDescription
Gets a description of the current state of the object. This field is usually the same as the Description() field, but it might be variable when overridden.
Public propertyInstanceGuid
Gets the ID of this runtime instance.
Public propertyKeywords
Gets a list of additional keywords that describe the object. Typically this list is empty but you can override this property to aid in object searches.
Public propertyName
Gets or sets the name of the object. This field typically remains fixed during the lifetime of an object.
Public propertyNickName
Gets or sets the nickname of the object. This field can be changed by the user.
Public propertySubCategory
Gets or sets the SubCategory in which this object belongs. If HasSubCategory() returns false, this field has no meaning.
Top
Methods
  NameDescription
Public methodCopyFrom
Copy all fields (except the instance ID) from another instance description.
Public methodNewInstanceGuid
Generate a new random instance GUID
Public methodNewInstanceGuid(Guid)
Set the instance ID to be a specific GUID. This is very dangerous, only use this function if you're 6"4' and your first name is David.
Public methodRead
Default deserialization. Only retrieves Name, NickName, Description and InstanceGuid fields. If you want to retrieve additional fields use ReadFull() instead. However, ReadFull() will only work if the archive was written using WriteFull().
Public methodReadFull
GH_InstanceDescription does not by default serialize all fields. Use this function to read all fields from the archive. This method is compatible with the default Write()/Read() operations.
Public methodWrite
Default serialization. Only stores Name, NickName, Description and InstanceGuid fields. If you want to store additional fields use WriteFull() instead.
Public methodWriteFull
GH_InstanceDescription does not by default serialize all fields. Use this function to write all fields to the archive. This method is compatible with the default Write()/Read() operations.
Top
See Also