Click or drag to resize

GH_FontPicker Class

Inheritance Hierarchy

Namespace:  Grasshopper.GUI
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_FontPicker : UserControl

The GH_FontPicker type exposes the following members.

Constructors
  NameDescription
Public methodGH_FontPicker
Initializes a new instance of the GH_FontPicker class
Top
Properties
  NameDescription
Public propertySelectedFont
Top
Methods
  NameDescription
Public methodStatic memberCreateFontPickerWindow
Create a new window containing a Font Picker object and OK, Cancel buttons. Picked fonts will be stored in the Tag field of the form.
Protected methodDispose
Releases the unmanaged resources used by the GH_FontPicker and optionally releases the managed resources
(Overrides ContainerControlDispose(Boolean).)
Public methodStatic memberShowFontPickerWindow(Font)
Display the fontpicker in a window.
Public methodStatic memberShowFontPickerWindow(Font, Form)
Display the fontpicker in a window.
Top
Extension Methods
  NameDescription
Public Extension MethodToEto (Defined by EtoExtensions.)
Top
See Also