GH_Field Class |
Namespace: Grasshopper.Kernel.Types
The GH_Field type exposes the following members.
Name | Description | |
---|---|---|
GH_Field |
Blank constructor.
| |
GH_Field(GH_Field) |
Copy constructor.
|
Name | Description | |
---|---|---|
ClippingBox | ||
Elements |
Gets the list of elements of this field.
| |
IsValid | ||
IsValidWhyNot | ||
TypeDescription | ||
TypeName |
Name | Description | |
---|---|---|
CastFrom | ||
CastToT | ||
CurvatureAt | ||
DrawViewportMeshes | ||
DrawViewportWires | ||
Duplicate | ||
EmitProxy | ||
Read | ||
ScriptVariable | ||
SolveStep |
Move a point through the field.
| |
SolveSteps |
Move a point through a succession of steps.
| |
TensorAt |
Compute the field tensor at the given location as contributed by all the field elements.
| |
ToString | ||
Write |