Click or drag to resize

IGH_FieldElement Interface

Represents the basic interface for field elements.

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public interface IGH_FieldElement : GH_ISerializable, 
	IGH_PreviewData

The IGH_FieldElement type exposes the following members.

Properties
  NameDescription
Public propertyBoundingBox
Gets the visual boundingbox of all the geometry used to represent this element in 3D.
Public propertyElementGuid
Gets the element Guid for this element.
Public propertyIsLimited
Gets or sets whether this element affects a limited region.
Public propertyLimits
Gets or sets the limits of this region. Unless IsLimited equals true, the Limits property is ignored.
Top
Methods
  NameDescription
Public methodDuplicate
Create an exact copy of this element.
Public methodForce
Compute the force at a given location.
Public methodIsCoincident
Computes whether the point can be considered coincident with the element.
Top
See Also