Click or drag to resize

IGH_GooProxy Interface

Base interface for all type proxies.

Namespace:  Grasshopper.Kernel.Types
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public interface IGH_GooProxy

The IGH_GooProxy type exposes the following members.

Properties
  NameDescription
Public propertyIsParsable
Gets a value indicating whether or not the type can be instantiated from a String.
Public propertyProxyOwner
Gets the piece of Grasshopper data that spawned this proxy.
Public propertyUserString
Gets or sets the user-defined string that describes this proxy. This only really makes sense if the Proxy is Parsable.
Public propertyValid
Gets a value indicating whether this proxy represents valid data.
Top
Methods
  NameDescription
Public methodConstruct
This method will be called when a new instance of this type is constructed. It allows implementers to supply a customized UI to be shown during construction. This method should never throw exceptions.
Public methodFormatInstance
Returns a String description of the current value.
Public methodFromString
If IsParsable(), then attempts to convert the string to a generic type value
Public methodMutateString
Munge a string to remove obvious errors on account of the user.
Top
See Also