Click or drag to resize

GH_RemoveObjectAction Class

Records a single object removal.
Inheritance Hierarchy

Namespace:  Grasshopper.Kernel.Undo.Actions
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_RemoveObjectAction : GH_ArchivedUndoAction

The GH_RemoveObjectAction type exposes the following members.

Constructors
  NameDescription
Public methodGH_RemoveObjectAction
Initializes a new instance of the GH_RemoveObjectAction class
Top
Properties
  NameDescription
Public propertyExpiresSolution (Overrides GH_UndoActionExpiresSolution.)
Top
Methods
  NameDescription
Protected methodInternal_Redo (Overrides GH_UndoActionInternal_Redo(GH_Document).)
Protected methodInternal_Undo (Overrides GH_UndoActionInternal_Undo(GH_Document).)
Top
Fields
  NameDescription
Top
See Also