Click or drag to resize

ModelRenderContentAttributes Class

Inheritance Hierarchy

Namespace:  Grasshopper.Rhinoceros.Render
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public abstract class Attributes : ModelContentAttributes, 
	IEquatable<ModelRenderContentAttributes>

The ModelRenderContentAttributes type exposes the following members.

Constructors
  NameDescription
Protected methodModelRenderContentAttributes
Initializes a new instance of the ModelRenderContentAttributes class
Protected methodModelRenderContentAttributes(RenderContent)
Initializes a new instance of the ModelRenderContentAttributes class
Top
Properties
Methods
  NameDescription
Protected methodEquals(Object, IEqualityComparer) (Overrides ModelContentAttributesEquals(Object, IEqualityComparer).)
Public methodStatic memberEquals(RenderContent, RenderContent)
Protected methodGetHashCode(IEqualityComparer) (Overrides ModelContentAttributesGetHashCode(IEqualityComparer).)
Protected methodReadData (Overrides ModelContentAttributesReadData(GH_IReader).)
Protected methodSubClone (Overrides ModelDataAttributesSubClone.)
Public methodToDetails (Overrides ModelDataAttributesToDetails.)
Protected methodWriteData (Overrides ModelContentAttributesWriteData(GH_IWriter).)
Top
See Also