Click or drag to resize

ModelContentAttributes Class

Inheritance Hierarchy
SystemObject
  Grasshopper.RhinocerosModelDataAttributes
    Grasshopper.RhinocerosModelContentAttributes
      More...

Namespace:  Grasshopper.Rhinoceros
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public abstract class Attributes : ModelDataAttributes, 
	IStructuralEquatable, IEquatable<ModelContentAttributes>

The ModelContentAttributes type exposes the following members.

Constructors
  NameDescription
Protected methodModelContentAttributes
Initializes a new instance of the ModelContentAttributes class
Top
Properties
  NameDescription
Protected propertyId
Public propertyName
The last component of the element Path.
Public propertyNotes
Public propertyParent
Path of the parent element in 'Root::Parent' format if nested.
Public propertyPath
Full content path in 'Root::Parent::Name' format if is nested.
Public propertyTags
Top
Methods
  NameDescription
Public methodEquals(Object) (Overrides ObjectEquals(Object).)
Protected methodEquals(Object, IEqualityComparer)
Public methodGetHashCode (Overrides ObjectGetHashCode.)
Protected methodGetHashCode(IEqualityComparer)
Protected methodIsValidContentName
Protected methodRead (Overrides ModelDataAttributesRead(GH_IReader).)
Protected methodReadData
Public methodToString (Overrides ModelDataAttributesToString.)
Protected methodWrite (Overrides ModelDataAttributesWrite(GH_IWriter).)
Protected methodWriteData
Top
See Also
Inheritance Hierarchy
SystemObject
  Grasshopper.RhinocerosModelDataAttributes
    Grasshopper.RhinocerosModelContentAttributes
      Grasshopper.Rhinoceros.DisplayModelDisplayModeAttributes
      Grasshopper.Rhinoceros.DisplayModelViewportAttributes
      Grasshopper.Rhinoceros.ModelModelEarthAnchorPointAttributes
      Grasshopper.RhinocerosModelComponentContentAttributes
      Grasshopper.Rhinoceros.RenderModelRenderContentAttributes
      Grasshopper.Rhinoceros.RenderModelRenderSkylightAttributes
      Grasshopper.Rhinoceros.RenderModelRenderSunAttributes