Description:

This method sets the frame buffer size and adds all the necessary wireframe channels automatically. It also creates the wireframe channel data automatically so that your renderer doesn't have to. You typically call this method only when your renderer does not support wireframe rendering itself. If you call this method, then you should not add any wireframe channels returned by GetRenderChannels(). If your renderer is capable of rendering the wireframe channels itself, you should not call this method. Instead, you must make sure you add the wireframe channels if GetRenderChannels() requests them. See IRhRdkRenderWindow::GetRenderChannels(). After the wires are rendered, the wireframe post effects will composite them into the final rendered image. Note: This method should really be called AddWireframeChannels(). [SDK_UNFREEZE] */

Syntax:
public bool AddWireframeChannel(
RhinoDoc doc,
ViewportInfo viewport,
Size size,
Rectangle region
)
Parameters:
  • doc
  • Type: RhinoDoc
  • The document to display
  • size
  • Type: System.Drawing.Size
  • The size of the image without clipping (i.e., if you have a region, it is the size of the image before you cut the region out.
  • region
  • Type: System.Drawing.Rectangle
  • The area of the rendering you want to display. This should match the size of the render window itself (i.e, - the one set using SetSize)
Returns:
Type: bool
Returns True if all of the wireframe channels were added successfully.
Available since:
5.0

/
/
/
AddWireframeChannel

AddWireframeChannel method

Class:  Rhino.Render.RenderWindow

Nothing found