Description:

Call this method to open the RenderWindow.StandardChannels.RGBA channel and set a block of color values

Syntax:
public void SetRGBAChannelColors(
Rectangle rectangle,
Color4f[] colors
)
Parameters:
  • rectangle
  • Type: System.Drawing.Rectangle
  • rectangle.X is the horizontal pixel position of the left edge. No validation is done on this value. The caller is responsible for ensuring that it is within the frame buffer. rectangle.Y is the vertical pixel position of the top edge. No validation is done on this value. The caller is responsible for ensuring that it is within the frame buffer. rectangle.Width is the width of the rectangle in pixels. No validation is done on this value. rectangle.Height is the height of the rectangle in pixels. No validation is done on this value.
Returns:
Type: void
Available since:
5.0

Description:

Call this method to open the RenderWindow.StandardChannels.RGBA channel and set a block of color values

Syntax:
public void SetRGBAChannelColors(
Size size,
Color4f[] colors
)
Parameters:
  • size
  • Type: System.Drawing.Size
  • Size of the area to set. No validation is done on this value
Returns:
Type: void
Available since:
5.0

/
/
/
SetRGBAChannelColors

SetRGBAChannelColors method

Class:  Rhino.Render.RenderWindow

Nothing found