Description:

Like RenderWindow.SaveRenderImageAs(string,Guid,bool), but with Guid set to Guid.Empty.

Syntax:
public void SaveRenderImageAs(
string filename,
bool saveAlpha
)
Parameters:
  • filename
  • Type: string
  • Filename of image file to be created
  • saveAlpha
  • Type: bool
  • True if alpha channel should be saved.
Returns:
Type: void
Available since:
6.0

Description:

Save current RenderWindow contents as an image file with the given name. The filetype will be determine. Pass in render engine Guid if an engine implements saving to a format that is not supported by Rhino. Guid.Empty if there is no need for that.

Syntax:
public void SaveRenderImageAs(
string filename,
Guid renderEngineGuid,
bool saveAlpha
)
Parameters:
  • filename
  • Type: string
  • Filename of image file to be created
  • renderEngineGuid
  • Type: System.Guid
  • render engine ID
  • saveAlpha
  • Type: bool
  • True if alpha channel should be saved.
Returns:
Type: void
Available since:
6.0

/
/
/
SaveRenderImageAs

SaveRenderImageAs method

Class:  Rhino.Render.RenderWindow

Nothing found