Description:

Fast access to bitmap evaluator - supply size (which you will probably have received from CRhRdkTexture::PixelSize) to see if the data can be extracted direct to a width*height*4 array of unsigned chars.

Syntax:
public virtual StdVectorByte WriteToByteArray2(
int width,
int height
)
virtual
Parameters:
  • width
  • Type: int
  • is the point for which to evaluate the texture.
  • height
  • Type: int
  • duvwdx is a ray differential.
Returns:
A ByteArray full of the byte values in RGBA order, or None if the function did not succeed
Available since:
7.0

WriteToByteArray2 method

Class:  Rhino.Render.TextureEvaluator

Nothing found