Description:

Fast access to bitmap evaluator - supply size (which you will probably have received from CRhRdkTexture::PixelSize) to see if the data can be extracted direct to a width*height*4 array of unsigned chars.

Syntax:
public virtual SimpleArrayFloat WriteToFloatArray(
int width,
int height
)
virtual
deprecated in 7.26
obsolete: Use WriteToFloatArray2 instead - supports much larger byte arrays
Parameters:
  • width
  • Type: int
  • is the point for which to evaluate the texture.
  • height
  • Type: int
  • duvwdx is a ray differential.
Returns:
A FloatArray full of the float values in RGBA order, or None if the function did not succeed.
Available since:
7.0

WriteToFloatArray method

Class:  Rhino.Render.TextureEvaluator

Nothing found