Description:

Optimized version of GetColor for callers. Much faster in the case of a native (C++) evaluator.

Syntax:
public bool GetColor(
Point3d uvw,
Vector3d duvwdx,
Vector3d duvwdy,
ref Color4f color
)
Parameters:
  • uvw
  • Type: Point3d
  • is the point for which to evaluate the texture.
  • duvwdx
  • Type: Vector3d
  • duvwdx is a ray differential.
  • duvwdy
  • Type: Vector3d
  • duvwdy is a ray differential.
Returns:
Type: bool
True if the evaluator returned a valid color. Otherwise false.
Available since:
7.0

Description:

Get the color of the texture at a particular point in uvw space. May be called from within a rendering shade pipeline. note For ray differentials see Pharr Humphreys, "Physically Based Rendering", chapter 11.

Syntax:
public virtual Color4f GetColor(
Point3d uvw,
Vector3d duvwdx,
Vector3d duvwdy
)
virtual
Parameters:
  • uvw
  • Type: Point3d
  • is the point for which to evaluate the texture.
  • duvwdx
  • Type: Vector3d
  • duvwdx is a ray differential.
  • duvwdy
  • Type: Vector3d
  • duvwdy is a ray differential.
Returns:
Type: Color4f
The texture color at this point in UV space.
Available since:
5.1

Nothing found