Namespace: Rhino.RenderUtilities: references
Utilities()
DefaultRenderPlugInId
ShowIncompatibleEnvironments
ShowIncompatibleMaterials
ShowIncompatibleTextures
ChangeContentType(RenderContent oldContent,Guid newType, bool harvestParameters)
FindFile(RhinoDoc doc, string fullPathToFile, bool unpackFromBitmapTableIfNecessary)
FindFile(RhinoDoc doc, string fullPathToFile)
GetUnpackedFilesCacheFolder(RhinoDoc doc, bool create)
IsCachedTextureFileInUse(string textureFileName)
LoadPersistentRenderContentFromFile(uint docSerialNumber,String filename)
MoveWindow(IntPtr hwnd,Rectangle rect, bool bRepaint, bool bRepaintNC)
PromptForSaveImageFileParameters(string filename, ref int width, ref int height, ref int colorDepth)
SafeFrameEnabled(RhinoDoc doc)
SetDefaultRenderPlugIn(Guid pluginId)
ShowContentChooser(RhinoDoc doc,Guid defaultType,Guid defaultInstanceId, RenderContentKind kinds, ContentChooserFlags flags, string presetCategory, IEnumerable<string> categories, IEnumerable<Guid> types,Guid[] instanceIdsOut)
ShowContentChooser(RhinoDoc doc,Guid defaultType,Guid defaultInstanceId, RenderContentKind kinds, ShowContentChooserFlags flags, string presetCategory, IEnumerable<string> categories, IEnumerable<Guid> types,Guid[] instanceIdsOut)
ShowContentChooser(Guid defaultType,Guid defaultInstanceId, RenderContentKind kinds,Guid instanceIdOut, ShowContentChooserFlags flags, RhinoDoc doc)
ShowIORMenu(IntPtr hwnd,Point pt, ref double outIOR, ref string outString)