Description:

Display and track the context menu.

Syntax:
public static bool ShowIORMenu(
IntPtr hwnd,
Point pt,
ref double outIOR,
ref string outString
)
Parameters:
  • hwnd
  • Type: System.IntPtr
  • The window that displays the menu, for example an edit box.
  • outIOR
  • Type: double
  • Accepts the IOR value of the user's chosen substance
  • outString
  • Type: string
  • Accepts the name of the user's chosen substance. Can be None if not required.
Returns:
Type: bool
True if the function showed the IOR menu and something was picked.
Available since:
6.0

ShowIORMenu method

Class:  Rhino.Render.Utilities

Nothing found