Description:

Load a Icon from an embedded resource and convert it to a bitmap of the specified size. Will look for a icon image that is greater than or equal to the requested size, if all images are less than the requested size the largest image will be used.

Syntax:
public static Bitmap BitmapFromIconResource(
string resourceName,
Size bitmapSize,
Assembly assembly
)
Parameters:
  • bitmapSize
  • Type: Size
  • Desired bitmap size
  • assembly
  • Type: System.Reflection.Assembly
  • The assembly containing the manifest resource, will use the calling assembly if null.
Returns:
Type: Bitmap
Available since:
6.0

Description:

Load a Icon from an embedded resource and convert it to a bitmap of the specified size. Will look for a icon image that is greater than or equal to the requested size, if all images are less than the requested size the largest image will be used.

Syntax:
public static Bitmap BitmapFromIconResource(
string resourceName,
Assembly assembly
)
Parameters:
  • assembly
  • Type: System.Reflection.Assembly
  • The assembly containing the manifest resource, will use the calling assembly if null.
Returns:
Type: Bitmap
Available since:
6.12

/
/
/
BitmapFromIconResource

BitmapFromIconResource method

Class:  Rhino.UI.DrawingUtilities

Nothing found