Description:

Get array of bytes that represent RGBA values for an image of a given size created from SVG

Syntax:
public static byte PixelsFromSvg(
string svg,
int width,
int height,
bool premultiplyAlpha,
Color backgroundColor
)
Parameters:
  • height
  • Type: int
  • premultiplyAlpha
  • Type: bool
  • Pre-lends the background color with the pixels based on their alpha value
  • backgroundColor
  • Type: Color
  • Background color - pass Color.Empty if you don't know what to pass.
Returns:
Type: byte
Available since:
8.0

PixelsFromSvg method

Class:  Rhino.UI.DrawingUtilities

Nothing found