PlugInId

Returns the identifier of a plug-in given the plug-in's name.

Syntax

Rhino.PlugInId (strPlugIn)

Parameters

strPlugIn

Required.  String.  The name of an existing plug-in.

Returns

String

The plug-in's identifier if successful.

Null

If not successful, or on error.

Example

Dim arrPlugins, strPlugin

arrPlugins = Rhino.PlugIns(0, 1)

If IsArray(arrPlugins) Then

For Each strPlugin In arrPlugins

Rhino.Print Rhino.PlugInId(strPlugin)

Next

End If

Also See

EnablePlugIn

IsPlugIn

PlugInIds

PlugInInfo

PlugInName

PlugIns