Returns the names of all registered plug-ins.
Rhino.PlugIns ([intTypes [, intStatus]])
intTypes |
Optional. Number. The type or types of plug-ins to return. Plug-in types can be added together to filter several different kinds of plug-ins. If omitted, all plug-in types are returned.
|
||||||||||||||
intStatus |
Optional. Number. The status, either loaded or unloaded, of the plug-ins to return. If omitted, both loaded and unloaded plug-ins are returned.
|
Array |
An array of plug-in names successful. |
Null |
If not successful, or on error. |
Dim arrPlugins, strPlugin
arrPlugins = Rhino.PlugIns(0, 1)
If IsArray(arrPlugins) Then
For Each strPlugin In arrPlugins
Rhino.Print strPlugin
Next
End If