PlugInInfo

Returned detailed information about a registered plug-in.

Syntax

Rhino.PlugInInfo (strPlugIn)

Parameters

strPlugIn

Required.  String.  The name or identifier of an existing plug-in.

Returns

Array

An array of detailed plug-in information if successful.  The array will contain the following information:

Element

Type

Description

0

String

The plug-in identifier.

1

String

The plug-in name.

2

String

The full path to the plug-in file.

3

String

The plug-in version.

4

Number

The version of the Rhino SDK that the plug-in requires.

5

Number

The service release of the Rhino SDK that the plug-in requires.

6

String

The developer or organization.

7

String

The developer address.

8

String

The developer country.

9

String

The developer e-mail address.

10

String

The developer phone number.

11

String

The developer FAX number.

12

String

The developer web site.

13

String

The developer update URL.

14

Number

The plug-in type. See PlugInIds or PlugIns for a list of plug-in type values.

15

Number

The plug-in load time, where 0 = disabled, 1 = load at startup, 2 = load on demand.

16

Boolean

True if the plug-in is loaded, False otherwise.

17

Boolean

True if the plug-in is disabled, False otherwise.

18

Boolean

True if the plug-in shipped with Rhino. False otherwise.

Null

If not successful, or on error.

Example

Dim arrPlugins, arrInfo, i

arrPlugins = Rhino.PlugInIds(0, 1)

arrInfo = Rhino.PlugInInfo(arrPlugin(0))

If IsArray(arrInfo) Then

For i = 0 to UBound(arrInfo)

Rhino.Print arrInfo(i)

Next

End If

Also See

EnablePlugIn

IsPlugIn

PlugInId

PlugInIds

PlugInName

PlugIns