DimStyleCentermarkSize

Returns or modifies the center mark size of a dimension style.

Syntax

Rhino.DimStyleCentermarkSize (strDimStyle [, dblSize])

Parameters

strDimStyle

Required.  String.  The name of an existing dimension style.

dblSize

Optional.  Number.  The new center mark size.  If omitted, the current center mark size is returned.

Returns

Number

If a size is not specified, the current center mark size if successful.

Number

If a size is specified, the previous center mark size if successful.

Null

If not successful, or on error.

Example

Dim strDimStyle, dblSize

strDimStyle = Rhino.CurrentDimStyle

dblSize = Rhino.DimStyleCentermarkSize(strDimStyle)

If dblSize > 0.5 Then

Rhino.DimStyleCentermarkSize strDimStyle, 0.5

End If

Also See

DimStyleAnglePrecision

DimStyleArrowSize

DimStyleFont

DimStyleLinearPrecision

DimStyleNumberFormat

DimStyleOffset

DimStyleTextAlignment

DimStyleTextHeight