TextObjectJustification

Returns or modifies the justification of a text object.

Syntax

Rhino.TextObjectJustification (strObject [, intJustification])

Parameters

strObject

Required.  String.  The identifier of the object.

intJustification

Optional. Number.  The justification.  If omitted, a Bottom-Left justification (0) is used.  The justification can be any number of the following flags:

Value

Description

0

Bottom-Left

1

Bottom-Center

2

Bottom-Right

3

Middle-Left

4

Middle-Center

5

Middle-Right

6

Top-Left

7

Top-Middle

8

Top-Right

Returns

Number

If a justification is not specified, the current justification if successful.

Number

If a justification is specified, the previous justification if successful.

Null

If not successful, or on error.

Example

Dim strObject

strObject = Rhino.GetObject("Select text")

If Rhino.IsText(strObject) Then

  Rhino.TextObjectJustification strObject, 0

End If

Also See

AddText

IsText

TextObjectFont

TextObjectFormula

TextObjectHeight

TextObjectPlane

TextObjectPoint

TextObjectStyle

TextObjectText