IsObjectChild

Verifies that an object is a history descendant, or child object. Child objects are the output of a history-supporting command. Note, is possible to an object to be both a history antecedent and a history descendant.

Syntax

Rhino.IsObjectChild (strObject)

Parameters

strObject

Required.  String.  The identifier of an object.

Returns

True

The object is a child object.

False

The object is not a child object.

Null

On error.

Example

Dim strObject

strObject = Rhino.GetObject

If Rhino.IsObjectChild(strObject) Then

  Rhino.Print "The object is a child object."

Else

  Rhino.Print "The object is not a child object."

End If

Also See

IsObjectParent

ObjectChildren

ObjectHasHistory

ObjectParents