ObjectParents

Returns the identifiers of history antecedents, or parents, of an object. Parent objects are the input to a history-supporting command.

Syntax

Rhino.ObjectParents (strObject)

Parameters

strObject

Required.  String.  The identifier of an object.

Returns

Array

An array of strings identifying the objects if successful.

Null

On error.

Example

Dim strObject, arrParent

strObject = Rhino.GetObject

arrParent = Rhino.ObjectParents(strObject)

If IsArray(arrParent) Then

  Call Rhino.SelectObjects(arrParent)

End If

Also See

IsObjectChild

IsObjectParent

ObjectChildren

ObjectHasHistory