IsObjectParent

Verifies that an object is a history antecedent, or parent object. Parent objects are the input to a history-supporting command. Note, is possible to an object to be both a history antecedent and a history descendant.

Syntax

Rhino.IsObjectParent (strObject)

Parameters

strObject

Required.  String.  The identifier of an object.

Returns

True

The object is a parent object.

False

The object is not a parent object.

Null

On error.

Example

Dim strObject

strObject = Rhino.GetObject

If Rhino.IsObjectParent(strObject) Then

  Rhino.Print "The object is a parent object."

Else

  Rhino.Print "The object is not a parent object."

End If

Also See

IsObjectChild

ObjectChildren

ObjectHasHistory

ObjectParents