ObjectChildren

Returns the identifiers of history descendants, or children, of a parent object. Child objects are the output of a history-supporting command.

Syntax

Rhino.ObjectChildren (strObject)

Parameters

strObject

Required.  String.  The identifier of an object.

Returns

Array

An array of strings identifying the objects if successful.

Null

On error.

Example

Dim strObject, arrChildren

strObject = Rhino.GetObject

arrChildren = Rhino.ObjectChildren(strObject)

If IsArray(arrChildren) Then

  Call Rhino.SelectObjects(arrChildren)

End If

Also See

IsObjectChild

IsObjectParent

ObjectHasHistory

ObjectParents