ObjectHasHistory

Verifies that an object has history. Objects with history were either the input to, or the output of a history-supporting command.

Syntax

Rhino.ObjectHasHistory (strObject)

Parameters

strObject

Required.  String.  The identifier of an object.

Returns

True

The object has history.

False

The object does not have history.

Null

On error.

Example

Dim strObject

strObject = Rhino.GetObject

If Rhino.ObjectHasHistory(strObject) Then

  Rhino.Print "The object has history."

Else

  Rhino.Print "The object does not have history."

End If

Also See

IsObjectChild

IsObjectParent

ObjectChildren

ObjectParents