Rhino C++ API  8.5
Public Member Functions | List of all members
CColorVec Class Reference

#include <RhinoSdkDisplayPipeline.h>

Inheritance diagram for CColorVec:
ON_4fPoint

Public Member Functions

 CColorVec (const ON_4fPoint &pt)
 
 CColorVec (float c)
 
 CColorVec (float R, float G, float B, float A=1.0f)
 
 CColorVec (int R, int G, int B, int A=255)
 
 CColorVec (ON_Color c)
 
 CColorVec (ON_Color c, float a)
 
 CColorVec (RGBQUAD c)
 
int Alpha () const
 
float Alphaf () const
 
int Blue () const
 
float Bluef () const
 
int Green () const
 
float Greenf () const
 
 operator ON_Color () const
 
CColorVec operator* (const CColorVec &p)
 
CColorVec operator* (const CColorVec &p) const
 
CColorVec operator* (float s)
 
CColorVec operator* (float s) const
 
CColorVec operator+ (const CColorVec &p)
 
CColorVec operator+ (const CColorVec &p) const
 
CColorVec operator- (const CColorVec &p)
 
CColorVec operator- (const CColorVec &p) const
 
CColorVecoperator= (BYTE c)
 
CColorVecoperator= (const ON_4fPoint &p)
 
CColorVecoperator= (const ON_Color &c)
 
CColorVecoperator= (float c)
 
CColorVecoperator= (UINT c)
 
int Red () const
 
float Redf () const
 
ON_Color ToON_Color () const
 
- Public Member Functions inherited from ON_4fPoint
 ON_4fPoint ()=default
 x,y,z,w not initialized More...
 
 ON_4fPoint (const double *)
 from double[4] array More...
 
 ON_4fPoint (const float *)
 Require explicit construction when dev must insure array has length >= 4. More...
 
 ON_4fPoint (const ON_2dPoint &)
 Require explicit construction when losing precision. More...
 
 ON_4fPoint (const ON_2dVector &)
 from 2d vector More...
 
 ON_4fPoint (const ON_2fPoint &)
 from 2f point More...
 
 ON_4fPoint (const ON_2fVector &)
 from 2f vector More...
 
 ON_4fPoint (const ON_3dPoint &)
 from 3d point More...
 
 ON_4fPoint (const ON_3dVector &)
 from 3d vector More...
 
 ON_4fPoint (const ON_3fPoint &)
 from 3f point More...
 
 ON_4fPoint (const ON_3fVector &)
 from 3f vector More...
 
 ON_4fPoint (const ON_4dPoint &)
 from 4d point More...
 
 ON_4fPoint (const ON_4fPoint &)=default
 
 ON_4fPoint (float x, float y, float z, float w)
 
 ~ON_4fPoint ()=default
 
ON__UINT32 DataCRC (ON__UINT32 current_remainder) const
 
float EuclideanX () const
 
float EuclideanY () const
 
float EuclideanZ () const
 
bool IsUnset () const
 
bool IsValid () const
 
double MaximumCoordinate () const
 absolute value of maximum coordinate More...
 
int MaximumCoordinateIndex () const
 
bool Normalize ()
 set so x^2 + y^2 + z^2 + w^2 = 1 More...
 
 operator const float * () const
 
 operator float * ()
 (float*) conversion operators More...
 
bool operator!= (const ON_4fPoint &rhs) const
 
ON_4fPoint operator* (float) const
 
ON_4fPointoperator*= (float)
 
ON_4fPoint operator+ (const ON_4fPoint &) const
 sum w = sqrt(w1*w2) More...
 
ON_4fPointoperator+= (const ON_4fPoint &)
 
ON_4fPoint operator- (const ON_4fPoint &) const
 difference w = sqrt(w1*w2) More...
 
ON_4fPointoperator-= (const ON_4fPoint &)
 
ON_4fPoint operator/ (float) const
 
ON_4fPointoperator/= (float)
 
ON_4fPointoperator= (const double *)
 point = double[4] support More...
 
ON_4fPointoperator= (const float *)
 point = float[4] support More...
 
ON_4fPointoperator= (const ON_2dPoint &)
 
ON_4fPointoperator= (const ON_2dVector &)
 
ON_4fPointoperator= (const ON_2fPoint &)
 use implicit operator=(const ON_4fPoint&) More...
 
ON_4fPointoperator= (const ON_2fVector &)
 
ON_4fPointoperator= (const ON_3dPoint &)
 
ON_4fPointoperator= (const ON_3dVector &)
 
ON_4fPointoperator= (const ON_3fPoint &)
 
ON_4fPointoperator= (const ON_3fVector &)
 
ON_4fPointoperator= (const ON_4dPoint &)
 
ON_4fPointoperator= (const ON_4fPoint &)=default
 
bool operator== (const ON_4fPoint &rhs) const
 
float operator[] (int) const
 index operators mimic float[4] behavior float& operator[](int); More...
 
float & operator[] (unsigned int)
 
float operator[] (unsigned int) const
 
void Set (float, float, float, float)
 set 4d point value More...
 
void Transform (const ON_Xform &)
 

Additional Inherited Members

- Static Public Member Functions inherited from ON_4fPoint
static int DictionaryCompare (const ON_4fPoint &lhs, const ON_4fPoint &rhs)
 
static int ProjectiveCompare (const ON_4fPoint &lhs, const ON_4fPoint &rhs)
 
- Public Attributes inherited from ON_4fPoint
float w
 
float x
 
float y
 
float z
 
- Static Public Attributes inherited from ON_4fPoint
static const ON_4fPoint Nan
 (ON_FLT_QNAN,ON_FLT_QNAN,ON_FLT_QNAN,ON_FLT_QNAN) More...
 
static const ON_4fPoint Zero
 (0,0,0,0) More...
 

Constructor & Destructor Documentation

◆ CColorVec() [1/7]

CColorVec::CColorVec ( ON_Color  c)
inline

◆ CColorVec() [2/7]

CColorVec::CColorVec ( ON_Color  c,
float  a 
)
inline

◆ CColorVec() [3/7]

CColorVec::CColorVec ( RGBQUAD  c)
inline

◆ CColorVec() [4/7]

CColorVec::CColorVec ( int  R,
int  G,
int  B,
int  A = 255 
)
inline

◆ CColorVec() [5/7]

CColorVec::CColorVec ( float  R,
float  G,
float  B,
float  A = 1.0f 
)
inline

◆ CColorVec() [6/7]

CColorVec::CColorVec ( float  c)
inline

◆ CColorVec() [7/7]

CColorVec::CColorVec ( const ON_4fPoint pt)
inline

Member Function Documentation

◆ Alpha()

int CColorVec::Alpha ( ) const
inline

◆ Alphaf()

float CColorVec::Alphaf ( ) const
inline

◆ Blue()

int CColorVec::Blue ( ) const
inline

◆ Bluef()

float CColorVec::Bluef ( ) const
inline

◆ Green()

int CColorVec::Green ( ) const
inline

◆ Greenf()

float CColorVec::Greenf ( ) const
inline

◆ operator ON_Color()

CColorVec::operator ON_Color ( ) const
inline

◆ operator*() [1/4]

CColorVec CColorVec::operator* ( const CColorVec p)
inline

◆ operator*() [2/4]

CColorVec CColorVec::operator* ( const CColorVec p) const
inline

◆ operator*() [3/4]

CColorVec CColorVec::operator* ( float  s)
inline

◆ operator*() [4/4]

CColorVec CColorVec::operator* ( float  s) const
inline

◆ operator+() [1/2]

CColorVec CColorVec::operator+ ( const CColorVec p)
inline

◆ operator+() [2/2]

CColorVec CColorVec::operator+ ( const CColorVec p) const
inline

◆ operator-() [1/2]

CColorVec CColorVec::operator- ( const CColorVec p)
inline

◆ operator-() [2/2]

CColorVec CColorVec::operator- ( const CColorVec p) const
inline

◆ operator=() [1/5]

CColorVec& CColorVec::operator= ( BYTE  c)
inline

◆ operator=() [2/5]

CColorVec& CColorVec::operator= ( const ON_4fPoint p)
inline

◆ operator=() [3/5]

CColorVec& CColorVec::operator= ( const ON_Color c)
inline

◆ operator=() [4/5]

CColorVec& CColorVec::operator= ( float  c)
inline

◆ operator=() [5/5]

CColorVec& CColorVec::operator= ( UINT  c)
inline

◆ Red()

int CColorVec::Red ( ) const
inline

◆ Redf()

float CColorVec::Redf ( ) const
inline

◆ ToON_Color()

ON_Color CColorVec::ToON_Color ( ) const
inline