#include <rhinoSdkFileOptions.h>
◆ CRhinoComponentNameConflictUI() [1/2]
CRhinoComponentNameConflictUI::CRhinoComponentNameConflictUI |
( |
| ) |
|
|
default |
◆ ~CRhinoComponentNameConflictUI()
CRhinoComponentNameConflictUI::~CRhinoComponentNameConflictUI |
( |
| ) |
|
|
default |
◆ CRhinoComponentNameConflictUI() [2/2]
◆ CommandResult()
◆ ComponentParentId()
ON_UUID CRhinoComponentNameConflictUI::ComponentParentId |
( |
| ) |
const |
◆ ComponentType()
◆ DefaultNewComponentName()
const ON_wString& CRhinoComponentNameConflictUI::DefaultNewComponentName |
( |
| ) |
const |
◆ DefaultResolutionMethod()
◆ DialogQuery()
◆ DialogTitle()
const ON_wString& CRhinoComponentNameConflictUI::DialogTitle |
( |
| ) |
const |
◆ Document()
CRhinoDoc* CRhinoComponentNameConflictUI::Document |
( |
| ) |
const |
◆ DocumentManifest()
Returns: The manifest for the current document.
◆ NameWithConflict()
const ON_wString& CRhinoComponentNameConflictUI::NameWithConflict |
( |
| ) |
const |
◆ NewComponentName()
const ON_wString& CRhinoComponentNameConflictUI::NewComponentName |
( |
| ) |
const |
◆ NewNameEditBoxDescription()
const ON_wString& CRhinoComponentNameConflictUI::NewNameEditBoxDescription |
( |
| ) |
const |
◆ NewNameIsValidAndUnique()
bool CRhinoComponentNameConflictUI::NewNameIsValidAndUnique |
( |
const wchar_t * |
new_name_candidate | ) |
const |
tools to determine how to resolve the name conflict Description: Tests new_name_candidate to see if it is valid and unique. If it is, both components can be used by changing the name of one to new_name_candidate. Parameters: new_name_candidate - [in] component name to test. Returns: True: new_name can be used to resolve the component name conflict.
◆ operator=()
◆ PermitCancel()
bool CRhinoComponentNameConflictUI::PermitCancel |
( |
| ) |
const |
Returns: true: The query user interface should permit canceling. false: The user must provide an answer.
◆ QueryMessage()
const ON_wString& CRhinoComponentNameConflictUI::QueryMessage |
( |
| ) |
const |
◆ ResolutionMethod()
◆ ScriptGetNewNameQuery()
Description: Script interface to get a new component name.
◆ ScriptQuery()
◆ ScriptQueryGetGetNamePrompt()
const ON_wString& CRhinoComponentNameConflictUI::ScriptQueryGetGetNamePrompt |
( |
| ) |
const |
◆ ScriptQueryGetGetOptionPrompt()
const ON_wString& CRhinoComponentNameConflictUI::ScriptQueryGetGetOptionPrompt |
( |
| ) |
const |
◆ SetComponentWithNameConflict()
void CRhinoComponentNameConflictUI::SetComponentWithNameConflict |
( |
const ON_ModelComponent & |
component | ) |
|
◆ SetDefaultNewComponentName()
bool CRhinoComponentNameConflictUI::SetDefaultNewComponentName |
( |
const wchar_t * |
default_new_component_name | ) |
|
◆ SetDefaultResolutionMethod()
◆ SetDialogTitle()
void CRhinoComponentNameConflictUI::SetDialogTitle |
( |
const wchar_t * |
dialog_title | ) |
|
input for dialog query Description: If no title is set, a default title is generated.
◆ SetDocument() [1/3]
void CRhinoComponentNameConflictUI::SetDocument |
( |
const CRhinoDoc & |
doc | ) |
|
input information for script and dialog query
◆ SetDocument() [2/3]
void CRhinoComponentNameConflictUI::SetDocument |
( |
const CRhinoDoc * |
doc | ) |
|
◆ SetDocument() [3/3]
void CRhinoComponentNameConflictUI::SetDocument |
( |
unsigned int |
rhino_doc_sn | ) |
|
◆ SetNewComponentName()
bool CRhinoComponentNameConflictUI::SetNewComponentName |
( |
const wchar_t * |
new_component_name | ) |
|
◆ SetNewNameEditBoxDescription()
void CRhinoComponentNameConflictUI::SetNewNameEditBoxDescription |
( |
const wchar_t * |
new_name_edit_box_description | ) |
|
If a script new name edit box description is not set, an appropriate one will be automatically generated.
◆ SetPermitCancel()
void CRhinoComponentNameConflictUI::SetPermitCancel |
( |
bool |
bPermitCancel | ) |
|
◆ SetQueryMessage()
void CRhinoComponentNameConflictUI::SetQueryMessage |
( |
const wchar_t * |
query_message | ) |
|
If a query message is not set, an appropriate one will be automatically generated.
◆ SetResolutionMethod()
◆ SetScriptQueryGetGetNamePrompt()
void CRhinoComponentNameConflictUI::SetScriptQueryGetGetNamePrompt |
( |
const wchar_t * |
script_query_get_name_prompt | ) |
|
If a script get name prompt is not set, an appropriate one will be automatically generated.
◆ SetScriptQueryGetGetOptionPrompt()
void CRhinoComponentNameConflictUI::SetScriptQueryGetGetOptionPrompt |
( |
const wchar_t * |
script_query_get_option_prompt | ) |
|
input for script query If a script get option prompt is not set, an appropriate one will be automatically generated.
◆ SetUpdateModelComponentRadioButtonDescription()
void CRhinoComponentNameConflictUI::SetUpdateModelComponentRadioButtonDescription |
( |
const wchar_t * |
update_model_component_radio_button_description | ) |
|
Description: If no radio button description is set, one is automatically generated.
◆ SetUseBothComponentsRadioButtonDescription()
void CRhinoComponentNameConflictUI::SetUseBothComponentsRadioButtonDescription |
( |
const wchar_t * |
use_both_components_radio_button_description | ) |
|
Description: If no radio button description is set, one is automatically generated.
◆ SetUseForAllCheckBoxDescription()
void CRhinoComponentNameConflictUI::SetUseForAllCheckBoxDescription |
( |
const wchar_t * |
for_all_check_box_description | ) |
|
If a use all check box description is not set, an appropriate one will be automatically generated.
◆ SetUseModelComponentRadioButtonDescription()
void CRhinoComponentNameConflictUI::SetUseModelComponentRadioButtonDescription |
( |
const wchar_t * |
use_model_component_radio_button_description | ) |
|
Description: If no radio button description is set, one is automatically generated.
◆ SetUseResolutionMethodForFutureConflicts()
void CRhinoComponentNameConflictUI::SetUseResolutionMethodForFutureConflicts |
( |
bool |
bUseResolutionMethodForFutureConflicts | ) |
|
◆ UpdateModelComponentRadioButtonDescription()
const ON_wString& CRhinoComponentNameConflictUI::UpdateModelComponentRadioButtonDescription |
( |
| ) |
const |
◆ UseBothComponentsRadioButtonDescription()
const ON_wString& CRhinoComponentNameConflictUI::UseBothComponentsRadioButtonDescription |
( |
| ) |
const |
◆ UseForAllCheckBoxDescription()
const ON_wString& CRhinoComponentNameConflictUI::UseForAllCheckBoxDescription |
( |
| ) |
const |
◆ UseModelComponentRadioButtonDescription()
const ON_wString& CRhinoComponentNameConflictUI::UseModelComponentRadioButtonDescription |
( |
| ) |
const |
◆ UseResolutionMethodForFutureConflicts()
bool CRhinoComponentNameConflictUI::UseResolutionMethodForFutureConflicts |
( |
| ) |
const |