Rhino C++ API
8.13
|
#include <rhinoSdkGetString.h>
Public Member Functions | |
CRhinoGetString () | |
CRhinoGetString (const CRhinoGet &) | |
prompt and options inherited More... | |
~CRhinoGetString () | |
CRhinoGet::result | GetLiteralString () |
CRhinoGet::result | GetString () |
CRhinoGetString & | operator= (const CRhinoGetString &) |
prompt and options inherited More... | |
Public Member Functions inherited from CRhinoGet | |
CRhinoGet (TYPE) | |
CRhinoGet (TYPE, const CRhinoGet &) | |
virtual | ~CRhinoGet () |
void | AcceptColor (BOOL32 b=true) |
bool | AcceptCustomWindowsMessage (UINT winmsg_id) |
void | AcceptNothing (BOOL32 b=true) |
void | AcceptNumber (bool b=true, bool bAcceptZero=true) |
void | AcceptPoint (BOOL32 b=true) |
void | AcceptString (BOOL32 b=true) |
void | AcceptUndo (BOOL32 b=true) |
call to allow user undo previous selection. More... | |
int | AddCommandOption (CRhinoCommandOptionName option_name, CRhinoCommandOptionValue option_value=CRhinoCommandOptionValue(nullptr, nullptr), BOOL32 bHiddenOption=false) |
int | AddCommandOption (CRhinoCommandOptionName option_name, double number_value) |
int | AddCommandOption (CRhinoCommandOptionName option_name, int number_value) |
int | AddCommandOptionColor (CRhinoCommandOptionName option_name, ON_Color *color_value, const wchar_t *option_prompt=nullptr) |
int | AddCommandOptionInteger (CRhinoCommandOptionName option_name, int *integer_value, const wchar_t *option_prompt=nullptr, double lower_limit=ON_UNSET_VALUE, double upper_limit=ON_UNSET_VALUE) |
int | AddCommandOptionList (CRhinoCommandOptionName option_name, const ON_SimpleArray< CRhinoCommandOptionValue > &list_values, int list_current_index) |
int | AddCommandOptionList (CRhinoCommandOptionName option_name, int list_current_index, CRhinoCommandOptionValue list0_value=CRhinoCommandOptionValue(nullptr, nullptr), CRhinoCommandOptionValue list1_value=CRhinoCommandOptionValue(nullptr, nullptr), CRhinoCommandOptionValue list2_value=CRhinoCommandOptionValue(nullptr, nullptr), CRhinoCommandOptionValue list3_value=CRhinoCommandOptionValue(nullptr, nullptr), CRhinoCommandOptionValue list4_value=CRhinoCommandOptionValue(nullptr, nullptr), CRhinoCommandOptionValue list5_value=CRhinoCommandOptionValue(nullptr, nullptr), CRhinoCommandOptionValue list6_value=CRhinoCommandOptionValue(nullptr, nullptr), CRhinoCommandOptionValue list7_value=CRhinoCommandOptionValue(nullptr, nullptr), CRhinoCommandOptionValue list8_value=CRhinoCommandOptionValue(nullptr, nullptr), CRhinoCommandOptionValue list9_value=CRhinoCommandOptionValue(nullptr, nullptr)) |
int | AddCommandOptionList (CRhinoCommandOptionName option_name, int list_values_count, const CRhinoCommandOptionValue *list_values, int list_current_index) |
int | AddCommandOptionNumber (CRhinoCommandOptionName option_name, double *number_value, const wchar_t *option_prompt=nullptr, BOOL32 bIntegerValue=false, double lower_limit=ON_UNSET_VALUE, double upper_limit=ON_UNSET_VALUE, int number_format=0) |
int | AddCommandOptionToggle (CRhinoCommandOptionName option_name, CRhinoCommandOptionValue option_off_value, CRhinoCommandOptionValue option_on_value, bool bToggleState, bool *bCurrentToggleState=nullptr) |
int | AddCommandOptionToggle (CRhinoCommandOptionName option_name, CRhinoCommandOptionValue option_off_value, CRhinoCommandOptionValue option_on_value, BOOL32 bToggleState, BOOL32 *bCurrentToggleState=nullptr) |
void | AddHiddenCommandOptionAlias (int option_index, const wchar_t *alias1, const wchar_t *alias2=nullptr, const wchar_t *alias3=nullptr, const wchar_t *alias4=nullptr) |
low level tool More... | |
void | ClearCommandOptions () |
Clear all command line options. More... | |
void | ClearDefault () |
ON_Color | Color () const |
Used to get color if Get*() returns CRhinoGet::color. More... | |
CRhinoCommand::result | CommandResult () const |
const ON_Color & | DefaultColor () const |
double | DefaultNumber () const |
unsigned int | DocumentRuntimeSerialNumber () const |
void | EnableTransparentCommands (BOOL32 bEnableTransparentCommands) |
BOOL32 | GotDefault () const |
bool | In2dGet () const |
these functions are used by CRhinoView::OnMouseDown/Move/Up - pretend they don't exist More... | |
bool | IsGetColor () const |
bool | IsGetMeshes () const |
bool | IsGetNumber () const |
bool | IsGetObject () const |
bool | IsGetOption () const |
bool | IsGetPoint () const |
bool | IsGetString () const |
RH_LINE | Line2d () const |
double | Number () const |
const CRhinoCommandOption * | Option () const |
int | OptionCount () const |
Get the number of available command line options. This information is useful when command flow depends on the existence of command line options. More... | |
int | OptionCurrentListOptionIndex () const |
int | OptionIndex () const |
CRhinoCommandOption::COMMAND_OPTION_TYPE | OptionType () const |
ON_4iRect | PickRect () const |
ON_3dPoint | Point () const |
Used to get point if Get*() returns CRhinoGet::point. More... | |
ON_2iPoint | Point2d () const |
ON_4iRect | Rectangle2d () const |
CRhinoGet::result | Result () const |
returns result of the Get*() call More... | |
unsigned int | SerialNumber () const |
low level tool used to identify the get More... | |
void | SetCommandPrompt (const wchar_t *prompt) |
void | SetCommandPromptDefault (const wchar_t *default_value) |
void | SetDefaultColor (ON_Color default_color) |
void | SetDefaultColor (ON_Color default_color, bool bUseAlpha) |
void | SetDefaultInteger (int default_integer) |
void | SetDefaultNumber (double default_number, const wchar_t *format=nullptr) |
void | SetDefaultPoint (ON_3dPoint default_point) |
void | SetDefaultString (const wchar_t *default_string) |
void | SetDocument (unsigned int rhino_doc_sn) |
void | SetOptionVaries (int option_index, bool bVaries) |
Set option that uses "option_name=value" format to show the value as "Varies". More... | |
void | SetVector (const ON_3dVector &v) |
void | SetWaitDuration (double seconds) |
const wchar_t * | String () const |
TYPE | Type () const |
ON_3dVector | Vector () const |
CRhinoView * | View () const |
MSG | WindowsMessage () const |
ON_3dPoint | WorldPoint1 () const |
ON_3dPoint | WorldPoint2 () const |
Protected Member Functions | |
CRhinoGetString (TYPE) | |
used by CRhinoGetColor, CRhinoGetNumber, and CRhinoGetOption More... | |
CRhinoGetString (TYPE, const CRhinoGet &) | |
Protected Member Functions inherited from CRhinoGet | |
CRhinoGet::result | AutoProcessOption () |
const CRhinoCommandOption * | CommandOptionAtIndex (int option_index) const |
int | CommandOptionCount () const |
see source for comments More... | |
virtual ON_Plane | GetCS (bool bWorldCoordinates, bool bRelativeCoordinates) |
Helper used by IsAcceptableInput when parsing points. More... | |
CRhinoGet::result | IsAcceptableInput (const class CRhEventToken &, BOOL32 bAcceptNumber, BOOL32 *bUpdatedOptionValue, CRhinoHistory *history) |
CRhinoGet & | operator= (const CRhinoGet &) |
void | PreGet () |
void | RemoveCommandOptions (int option_index) |
see source for comments More... | |
virtual void | SetCommandWndPrompt () const |
void | SetOptionAccelerators () |
Copyright (c) 1993-2017 Robert McNeel & Associates. All rights reserved. Rhinoceros is a registered trademark of Robert McNeel & Associates.
THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT EXPRESS OR IMPLIED WARRANTY. ALL IMPLIED WARRANTIES OF FITNESS FOR ANY PARTICULAR PURPOSE AND OF MERCHANTABILITY ARE HEREBY DISCLAIMED.
For complete Rhino SDK copyright information see http://www.rhino3d.com/developer.
CRhinoGetString::CRhinoGetString | ( | ) |
CRhinoGetString::~CRhinoGetString | ( | ) |
CRhinoGetString::CRhinoGetString | ( | const CRhinoGet & | ) |
prompt and options inherited
|
protected |
used by CRhinoGetColor, CRhinoGetNumber, and CRhinoGetOption
STEP 4: Use result code returned by GetString() to determine what CRhinoGet function to call to get the input.
result function CRhinoGet::cancel user pressed ESCAPE CRhinoGet::nothing user pressed ENTER CRhinoGet::undo user wants to UNDO CRhinoGet::option CRhinoGet::Option() CRhinoGet::number CRhinoGet::Number() CRhinoGet::string CRhinoGet::String()
CRhinoGet::result CRhinoGetString::GetLiteralString | ( | ) |
CRhinoGet::result CRhinoGetString::GetString | ( | ) |
STEP 1: Use CRhinoGet member functions to specify command prompt and command options. STEP 2: Use CRhinoGet member functions to specify what types of alternate input can be accepted. STEP 3: Call GetString() or GetLiteralString() to get a string. GetString() is the standard and you should almost always use this. GetLiteralString() is used to get the entire line (up to an Enter key press or a new-line in a script file.). For example, GetLiteralString() is used to get input for lisp, python, etc. scripts.
CRhinoGetString& CRhinoGetString::operator= | ( | const CRhinoGetString & | ) |
prompt and options inherited