#include <RhinoSdkHistoryRecordTable.h>
◆ CreateObjectHistory()
Description: Command authors fill in a CRhinoHistory, create CRhinoObjects, and call SaveObjectHistory to put the information in the document.
◆ DestroyObjectHistory()
void CRhinoHistoryRecordTable::DestroyObjectHistory |
( |
CRhinoObject * |
object | ) |
|
◆ Document()
CRhinoDoc& CRhinoHistoryRecordTable::Document |
( |
| ) |
const |
Returns: CRhinoDoc that owns this history record table.
◆ GetHistoryDescendants()
Description: Object history tool that returns the list of objects that used this object during their construction. Parameters: antecedent_object - [in] uuid_list - [out] Returns: Number of ids appended to uuid_list[]
◆ GetPrunedHistoryRecord()
ON_HistoryRecord* CRhinoHistoryRecordTable::GetPrunedHistoryRecord |
( |
int |
record_index | ) |
|
26 May 2015, Mikko, RH-30481:
Description: Get a copy of a history record with objects that no longer have history record attached to them purged from m_descendants list. Returns: History record copy. The caller is responsible for deleting the copy when done.
◆ HistoryRecordCount()
int CRhinoHistoryRecordTable::HistoryRecordCount |
( |
| ) |
const |
Temporary - probably never needed.
◆ HistoryRecordingEnabled()
bool CRhinoHistoryRecordTable::HistoryRecordingEnabled |
( |
| ) |
const |
◆ IsHistoryDescendant()
bool CRhinoHistoryRecordTable::IsHistoryDescendant |
( |
const CRhinoObject * |
antecedent_object, |
|
|
ON_UUID |
descendant_uuid |
|
) |
| const |
Description: Object history tool that checks to see if an id is in the list of descendants. Parameters: descendant_uuid - [in] id to look for in the descendant list. Returns: True if descendant_uuid was found in the list of descendants.
◆ ListTable()
void CRhinoHistoryRecordTable::ListTable |
( |
ON_TextLog & |
text_log, |
|
|
unsigned int |
level_of_detail |
|
) |
| const |
◆ operator[]()
◆ PurgeHistory()
int CRhinoHistoryRecordTable::PurgeHistory |
( |
| ) |
|
Description: Purge all history information. Returns: number of objects that had records purged.
◆ PurgeHistoryRecord()
int CRhinoHistoryRecordTable::PurgeHistoryRecord |
( |
ON_UUID |
history_record_id | ) |
|
Description: Purge a single history record. This cannot be undone. Parameters: history_record_id - [in] id of the record to purge. Returns: 0: no changes >0: 1 + number of objects that had records purged.
◆ SetRemapIndex()
void CRhinoHistoryRecordTable::SetRemapIndex |
( |
int |
record_index, |
|
|
int |
remap_index |
|
) |
| |
◆ CRhinoDoc