CRhinoUiDockBarExpandableTabCtrl.
More...
#include <RhinoSdkUiDockBarExpandableTabCtrl.h>
◆ CRhinoUiDockBarExpandableTabCtrl()
CRhinoUiDockBarExpandableTabCtrl::CRhinoUiDockBarExpandableTabCtrl |
( |
| ) |
|
◆ ~CRhinoUiDockBarExpandableTabCtrl()
virtual CRhinoUiDockBarExpandableTabCtrl::~CRhinoUiDockBarExpandableTabCtrl |
( |
| ) |
|
|
virtual |
◆ CreateExpandableTabCtrl()
bool CRhinoUiDockBarExpandableTabCtrl::CreateExpandableTabCtrl |
( |
CRhinoUiDockBar * |
pParent | ) |
|
Description: Create window to hold the tab control. This window will size itself to fit the entire client area of the dock bar it is embedded in. If window is created successfully then a tab control will be created and embedded in this window. Parameters: pParent [in] Dock bar to embed window in. Returns: Returns true if this window and the tab control associated with it are created successfully.
◆ GetExpandableTabCtrl()
Description: Get tab control embedded in this window
◆ GetMargins()
CSize CRhinoUiDockBarExpandableTabCtrl::GetMargins |
( |
| ) |
const |
Description: Margins on left, right, top and bottom of this child tab control. Size::cx is left and right margins Size::cy is top and bottom margins Returns: Margin values
◆ GetRhinoDockBar()
Description: Get pointer to dock bar this window is embedded in.
◆ OnLButtonDblClk()
afx_msg void CRhinoUiDockBarExpandableTabCtrl::OnLButtonDblClk |
( |
UINT |
nFlags, |
|
|
CPoint |
point |
|
) |
| |
◆ OnLButtonDown()
afx_msg void CRhinoUiDockBarExpandableTabCtrl::OnLButtonDown |
( |
UINT |
nFlags, |
|
|
CPoint |
point |
|
) |
| |
◆ OnPaint()
afx_msg void CRhinoUiDockBarExpandableTabCtrl::OnPaint |
( |
| ) |
|
◆ OnSize()
afx_msg void CRhinoUiDockBarExpandableTabCtrl::OnSize |
( |
UINT |
nType, |
|
|
int |
cx, |
|
|
int |
cy |
|
) |
| |
◆ SetMargins()
void CRhinoUiDockBarExpandableTabCtrl::SetMargins |
( |
CSize |
size | ) |
|
Description: Set margins on left, right, top and bottom of this child tab control. Size::cx is left and right margins Size::cy is top and bottom margins Parameters: size [in] New margin values
◆ m_margins
CSize CRhinoUiDockBarExpandableTabCtrl::m_margins |
|
protected |
◆ m_pCB