Rhino C++ API
8.13
|
CRhinoUiDragBitmapWnd. More...
#include <RhinoSdkUiDragBitmapWnd.h>
Public Member Functions | |
CRhinoUiDragBitmapWnd () | |
virtual | ~CRhinoUiDragBitmapWnd () |
bool | CreateBitmapDragWindow (const CRhinoDib &dib, CWnd *pWndParent=NULL) |
bool | OffsetLeft () const |
afx_msg BOOL32 | OnEraseBkgnd (CDC *pDC) |
afx_msg void | OnPaint () |
void | SetBasePoint (CPoint pt) |
void | SetBitapTransparentColor (COLORREF cr) |
bool | SetDragBitmap (const CRhinoDib &dib) |
void | SetOffset (CSize szOffset) |
bool | SetOffsetLeft (bool b) |
bool | ShowDragWindow (bool bShow, LPPOINT pPtScreen) |
bool | TrackDragWindow (CPoint ptScreen) |
Public Attributes | |
int | m_dib_id |
Protected Attributes | |
bool | m_bOffsetLeft |
CRhinoDib | m_dib |
HWND | m_hWndParent |
CPoint | m_ptBase |
CString | m_sWndCls |
CSize | m_szOffset |
/ / Copyright (c) 1993-2007 Robert McNeel & Associates. All rights reserved. / Rhinoceros is a registered trademark of Robert McNeel & Associates. / / THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT EXPRESS OR IMPLIED WARRANTY. / ALL IMPLIED WARRANTIES OF FITNESS FOR ANY PARTICULAR PURPOSE AND OF / MERCHANTABILITY ARE HEREBY DISCLAIMED. /
/ For complete Rhino SDK copyright information see http://www.rhino3d.com/developer. / //////////////////////////////////////////////////////////////
CRhinoUiDragBitmapWnd::CRhinoUiDragBitmapWnd | ( | ) |
|
virtual |
bool CRhinoUiDragBitmapWnd::CreateBitmapDragWindow | ( | const CRhinoDib & | dib, |
CWnd * | pWndParent = NULL |
||
) |
bool CRhinoUiDragBitmapWnd::OffsetLeft | ( | ) | const |
afx_msg BOOL32 CRhinoUiDragBitmapWnd::OnEraseBkgnd | ( | CDC * | pDC | ) |
afx_msg void CRhinoUiDragBitmapWnd::OnPaint | ( | ) |
void CRhinoUiDragBitmapWnd::SetBasePoint | ( | CPoint | pt | ) |
void CRhinoUiDragBitmapWnd::SetBitapTransparentColor | ( | COLORREF | cr | ) |
bool CRhinoUiDragBitmapWnd::SetDragBitmap | ( | const CRhinoDib & | dib | ) |
void CRhinoUiDragBitmapWnd::SetOffset | ( | CSize | szOffset | ) |
bool CRhinoUiDragBitmapWnd::SetOffsetLeft | ( | bool | b | ) |
bool CRhinoUiDragBitmapWnd::ShowDragWindow | ( | bool | bShow, |
LPPOINT | pPtScreen | ||
) |
bool CRhinoUiDragBitmapWnd::TrackDragWindow | ( | CPoint | ptScreen | ) |
|
protected |
|
protected |
int CRhinoUiDragBitmapWnd::m_dib_id |
|
protected |
|
protected |
|
protected |
|
protected |