Rhino C++ API
8.17
|
#include <RhinoSdkUiOptionsListCtrlItem.h>
Protected Attributes | |
bool | m_bDrawSeparatorLine |
![]() | |
CPoint | m_ptEndTrackSelect |
CRhinoUiOptionsListCtrlSeparator::CRhinoUiOptionsListCtrlSeparator | ( | LPCTSTR | lpsLabel = NULL , |
int | iIndentLevel = 0 |
||
) |
Description: Constructor
Parameters: lpsLabel [in] Label for this item, appears in left column of options list lpsText [in] Text associated with this item, appears in right column of options list
See Also: CRhinoUiOptionsListCtrlItem::CRhinoUiOptionsListCtrlItem()
|
virtual |
Description: Destructor
|
virtual |
Description: This method is called when a options list control item is selected. The method should create the control window used to change the items value.
Parameters: list_ctrl [in] The options list control calling this method. rEdit [in] The options list control item value bounding rectangle.
Returns: Should return true if the control has been successfully created; otherwise false.
Implements CRhinoUiOptionsListCtrlItem.
bool CRhinoUiOptionsListCtrlSeparator::DrawSeparatorLine | ( | ) | const |
|
virtual |
Description: This method is called to determine height for this options list control item. Override this method if you want to increase the height of this item.
Returns: Returns height for this item.
See Also: CRhinoUiOptionsListCtrl::LabelItemHeight()
Reimplemented from CRhinoUiOptionsListCtrlItem.
|
virtual |
Description: This method is called when a column or options list control has been resized while a item control is visible.
Parameters: list_ctrl [in] The list control this item is inserted in. rEdit [in] The options list control item value bounding rectangle.
See Also: CRhinoUiOptionsListCtrlItem::BeginEditItem()
Implements CRhinoUiOptionsListCtrlItem.
|
virtual |
Description: This method is overridden to display separator line if enabled
Parameters: See: CRhinoUiOptionsListCtrlItem::OnDrawItem()
See Also: CRhinoUiOptionsListCtrlItem::OnDrawItem()
Reimplemented from CRhinoUiOptionsListCtrlItem.
bool CRhinoUiOptionsListCtrlSeparator::SetDrawSeparatorLine | ( | bool | b | ) |
|
virtual |
Description: This method is used to set text value for this item. This value is displayed in the right column of the options list control.
Parameters: lps [in] New display text for this item.
See Also: CRhinoUiOptionsListCtrl::Text() CRhinoUiOptionsListCtrl::DrawItemText()
Reimplemented from CRhinoUiOptionsListCtrlItem.
|
protected |