Rhino C++ API
8.13
|
#include <RhinoSdkUiWindowsPaintManager.h>
Public Member Functions | |
CRhinoUiPaintManager () | |
~CRhinoUiPaintManager () | |
COLORREF | ColorButtonBitmapMask () const |
COLORREF | ColorButtonEdge () const |
COLORREF | ColorButtonEdgeHighlight () const |
COLORREF | ColorButtonEdgeShadow () const |
COLORREF | ColorButtonFace (bool inactive_color=false) const |
COLORREF | ColorButtonHot () const |
COLORREF | ColorButtonPushed () const |
COLORREF | ColorButtonText (bool inactive_color=false) const |
COLORREF | ColorCaptonText (bool inactive_color=false) const |
COLORREF | ColorClientBackground () const |
COLORREF | ColorDockBarClientBackground () const |
COLORREF | ColorExpandableTab (bool inactive_color=false) const |
COLORREF | ColorExpandableTabText (bool inactive_color=false) const |
COLORREF | ColorGripperBars () const |
COLORREF | ColorItem (bool selected, bool inactive_color=false, bool separator=false) const |
COLORREF | ColorItemText (bool selected, bool inactive_color=false, bool separator=false) const |
COLORREF | ColorItemValue (bool selected, bool inactive_color=false) const |
COLORREF | ColorItemValueText (bool selected, bool inactive_color=false) const |
COLORREF | ColorNCBackground () const |
COLORREF | ColorTransparentNCDraw () const |
DrawExpanderHeaderOptions | DefaultDrawExpanderHeaderOptions () const |
void | DrawDividerLine (CDC &dc, const CRect ÷rRect, bool enabled, bool horizontal=true, COLORREF lineColor=ON_UNSET_COLOR, COLORREF disabledLineColor=ON_UNSET_COLOR) |
void | DrawDockBarGripper (CDC &dc, CRect rGripper, int dock_location) |
bool | DrawExpandableTabCtrlBkgnd (HWND hWnd, CDC *pDC, CRhinoUiThemeDraw *pThemeDraw) |
bool | DrawExpandableTabHeaderBkgnd (CDC &dc, const CRect &rect, CRhinoUiThemeDraw *pThemeDraw, bool bSpecial) |
bool | DrawExpandableTabHeaderForegnd (CDC &dc, const CRect &rect, CRhinoUiThemeDraw *pThemeDraw, bool bSpecial, bool bHot, bool bExpanded, const CString &text) |
bool | DrawExpandableTabPageBkgnd (HWND hWnd, CDC *pDC, CRhinoUiThemeDraw *pThemeDraw, bool bSpecial) |
void | DrawExpanderHeader (CDC &dc, const CRect &headerRect, int leftMargin, int rightMargin, const wchar_t *text, DrawExpanderHeaderOptions options, COLORREF bkgrndColor=ON_UNSET_COLOR, COLORREF textColor=ON_UNSET_COLOR, COLORREF disabledTextColor=ON_UNSET_COLOR, COLORREF separatorLineColor=ON_UNSET_COLOR, COLORREF disabledseparatorLineColor=ON_UNSET_COLOR) |
COLORREF | DrawExpanderHeaderDefaultColor (ExpanderHeaderDefaultColorPart part) const |
int | DrawExpandIcon (CDC &dc, int x, int y, bool expanded) |
bool | DrawGradientTitleRect (CDC *pDC, LPRECT lpRect, const wchar_t *lpsCaption, bool bActiveWindow, bool bVerticalRect=false) |
bool | DrawNcWindowFrame (CWnd &wnd, CDC &dc, bool bSmallCaption, bool bActive, LPRECT lprWin=NULL, LPRECT lprClient=NULL, LPRECT lprCaption=NULL) |
bool | DrawTitleText (CDC *pDC, LPRECT lpRect, const wchar_t *lpsCaption, bool bActiveWindow, bool bVerticalRect=false) |
CBrush * | GetExpandableTabPageBkgndBrush (CRhinoUiThemeDraw *pThemeDraw, bool bSpecial) |
CFont * | GetUiFont (FontSize size=FontSize::Normal, FontStyle style=FontStyle::Regular) |
void | Initialize () |
void | PaintDockBarClientArea (CControlBar &cb, CDC &dc) |
CSize | SmallCaptionButtonSize () const |
|
strong |
|
strong |
|
strong |
|
strong |
CRhinoUiPaintManager::CRhinoUiPaintManager | ( | ) |
CRhinoUiPaintManager::~CRhinoUiPaintManager | ( | ) |
COLORREF CRhinoUiPaintManager::ColorButtonBitmapMask | ( | ) | const |
COLORREF CRhinoUiPaintManager::ColorButtonEdge | ( | ) | const |
COLORREF CRhinoUiPaintManager::ColorButtonEdgeHighlight | ( | ) | const |
COLORREF CRhinoUiPaintManager::ColorButtonEdgeShadow | ( | ) | const |
COLORREF CRhinoUiPaintManager::ColorButtonFace | ( | bool | inactive_color = false | ) | const |
COLORREF CRhinoUiPaintManager::ColorButtonHot | ( | ) | const |
COLORREF CRhinoUiPaintManager::ColorButtonPushed | ( | ) | const |
COLORREF CRhinoUiPaintManager::ColorButtonText | ( | bool | inactive_color = false | ) | const |
COLORREF CRhinoUiPaintManager::ColorCaptonText | ( | bool | inactive_color = false | ) | const |
COLORREF CRhinoUiPaintManager::ColorClientBackground | ( | ) | const |
COLORREF CRhinoUiPaintManager::ColorDockBarClientBackground | ( | ) | const |
COLORREF CRhinoUiPaintManager::ColorExpandableTab | ( | bool | inactive_color = false | ) | const |
COLORREF CRhinoUiPaintManager::ColorExpandableTabText | ( | bool | inactive_color = false | ) | const |
COLORREF CRhinoUiPaintManager::ColorGripperBars | ( | ) | const |
COLORREF CRhinoUiPaintManager::ColorItem | ( | bool | selected, |
bool | inactive_color = false , |
||
bool | separator = false |
||
) | const |
COLORREF CRhinoUiPaintManager::ColorItemText | ( | bool | selected, |
bool | inactive_color = false , |
||
bool | separator = false |
||
) | const |
COLORREF CRhinoUiPaintManager::ColorItemValue | ( | bool | selected, |
bool | inactive_color = false |
||
) | const |
COLORREF CRhinoUiPaintManager::ColorItemValueText | ( | bool | selected, |
bool | inactive_color = false |
||
) | const |
COLORREF CRhinoUiPaintManager::ColorNCBackground | ( | ) | const |
COLORREF CRhinoUiPaintManager::ColorTransparentNCDraw | ( | ) | const |
DrawExpanderHeaderOptions CRhinoUiPaintManager::DefaultDrawExpanderHeaderOptions | ( | ) | const |
void CRhinoUiPaintManager::DrawDividerLine | ( | CDC & | dc, |
const CRect & | dividerRect, | ||
bool | enabled, | ||
bool | horizontal = true , |
||
COLORREF | lineColor = ON_UNSET_COLOR , |
||
COLORREF | disabledLineColor = ON_UNSET_COLOR |
||
) |
void CRhinoUiPaintManager::DrawDockBarGripper | ( | CDC & | dc, |
CRect | rGripper, | ||
int | dock_location | ||
) |
bool CRhinoUiPaintManager::DrawExpandableTabCtrlBkgnd | ( | HWND | hWnd, |
CDC * | pDC, | ||
CRhinoUiThemeDraw * | pThemeDraw | ||
) |
bool CRhinoUiPaintManager::DrawExpandableTabHeaderBkgnd | ( | CDC & | dc, |
const CRect & | rect, | ||
CRhinoUiThemeDraw * | pThemeDraw, | ||
bool | bSpecial | ||
) |
bool CRhinoUiPaintManager::DrawExpandableTabHeaderForegnd | ( | CDC & | dc, |
const CRect & | rect, | ||
CRhinoUiThemeDraw * | pThemeDraw, | ||
bool | bSpecial, | ||
bool | bHot, | ||
bool | bExpanded, | ||
const CString & | text | ||
) |
bool CRhinoUiPaintManager::DrawExpandableTabPageBkgnd | ( | HWND | hWnd, |
CDC * | pDC, | ||
CRhinoUiThemeDraw * | pThemeDraw, | ||
bool | bSpecial | ||
) |
void CRhinoUiPaintManager::DrawExpanderHeader | ( | CDC & | dc, |
const CRect & | headerRect, | ||
int | leftMargin, | ||
int | rightMargin, | ||
const wchar_t * | text, | ||
DrawExpanderHeaderOptions | options, | ||
COLORREF | bkgrndColor = ON_UNSET_COLOR , |
||
COLORREF | textColor = ON_UNSET_COLOR , |
||
COLORREF | disabledTextColor = ON_UNSET_COLOR , |
||
COLORREF | separatorLineColor = ON_UNSET_COLOR , |
||
COLORREF | disabledseparatorLineColor = ON_UNSET_COLOR |
||
) |
COLORREF CRhinoUiPaintManager::DrawExpanderHeaderDefaultColor | ( | ExpanderHeaderDefaultColorPart | part | ) | const |
int CRhinoUiPaintManager::DrawExpandIcon | ( | CDC & | dc, |
int | x, | ||
int | y, | ||
bool | expanded | ||
) |
bool CRhinoUiPaintManager::DrawGradientTitleRect | ( | CDC * | pDC, |
LPRECT | lpRect, | ||
const wchar_t * | lpsCaption, | ||
bool | bActiveWindow, | ||
bool | bVerticalRect = false |
||
) |
bool CRhinoUiPaintManager::DrawNcWindowFrame | ( | CWnd & | wnd, |
CDC & | dc, | ||
bool | bSmallCaption, | ||
bool | bActive, | ||
LPRECT | lprWin = NULL , |
||
LPRECT | lprClient = NULL , |
||
LPRECT | lprCaption = NULL |
||
) |
bool CRhinoUiPaintManager::DrawTitleText | ( | CDC * | pDC, |
LPRECT | lpRect, | ||
const wchar_t * | lpsCaption, | ||
bool | bActiveWindow, | ||
bool | bVerticalRect = false |
||
) |
CBrush* CRhinoUiPaintManager::GetExpandableTabPageBkgndBrush | ( | CRhinoUiThemeDraw * | pThemeDraw, |
bool | bSpecial | ||
) |
CFont* CRhinoUiPaintManager::GetUiFont | ( | FontSize | size = FontSize::Normal , |
FontStyle | style = FontStyle::Regular |
||
) |
void CRhinoUiPaintManager::Initialize | ( | ) |
void CRhinoUiPaintManager::PaintDockBarClientArea | ( | CControlBar & | cb, |
CDC & | dc | ||
) |
CSize CRhinoUiPaintManager::SmallCaptionButtonSize | ( | ) | const |