Rhino C++ API
8.13
|
#include <IRhRdkContentUI.h>
Public Member Functions | |
virtual void | AddSection (IRhinoUiSection *pSection)=0 |
virtual RDK_INTERNAL void | AddSection (IRhinoUiSection *pSection, CRhRdkControllerPtr con)=0 |
virtual IRhinoUiHolder * | ContentUIHolder (void) const =0 |
Public Member Functions inherited from IRhRdkContentUI | |
virtual void | AddClient (const CRhRdkContent &c)=0 |
RDK_DEPRECATED void | AddClient (CRhRdkCoreContent &c) |
virtual RDK_DEPRECATED void | AddSection (class CRhRdkExpandingSection *pSection, int dummy=0) |
virtual int | ClientCount (void) const =0 |
virtual RDK_INTERNAL CRhRdkControllerPtr | Controller (void) const =0 |
virtual ON_wString | DebugString (void) const =0 |
virtual void | DeleteThis (void)=0 |
virtual void | Destroy (void)=0 |
virtual void | DisplayData (void)=0 |
virtual UUID | EditorUuid (void) const =0 |
virtual void | Enable (bool bEnable)=0 |
virtual void | EnableDisableControls (void)=0 |
virtual void * | EVF (const wchar_t *, void *)=0 |
virtual RhRdkUiFrameworks | Framework (void) const =0 |
virtual RDK_DEPRECATED class IRhinoUiHolder & | Holder (void) const |
virtual bool | IsCreated (void) const =0 |
virtual bool | IsShown (void) const =0 |
virtual void | ReleaseAllClients (void)=0 |
virtual void | RemClient (const CRhRdkContent &c)=0 |
RDK_DEPRECATED void | RemClient (CRhRdkCoreContent &c) |
virtual RDK_INTERNAL void | SetController (CRhRdkControllerPtr con)=0 |
virtual void | SetPositionAndSize (const ON_4iRect &rect)=0 |
virtual void | SetSelection (const CRhRdkContentArray &aContent)=0 |
virtual void | Show (bool bShow)=0 |
virtual UUID | Uuid (void) const =0 |
Additional Inherited Members | |
Static Public Member Functions inherited from IRhRdkContentUI | |
static RDK_DEPRECATED IRhRdkContentUI * | Get (const UUID &) |
Protected Member Functions inherited from IRhRdkContentUI | |
virtual | ~IRhRdkContentUI () |
This interface extends IRhRdkContentUI to represent the default user interface which the RDK provides for a content. This is the UI created by the default implementation of CRhRdkCoreContent::CreateUI(). The main feature of this implementation is a 'holder' containing one or more expandable 'sections' (AKA 'roll-ups').
|
pure virtual |
Add a section to the UI. Called before Create(). A generic controller is attached.
|
pure virtual |
|
pure virtual |
Implements IRhRdkContentUI.