Rhino C++ API  8.6
Public Member Functions | Protected Member Functions | List of all members
IRhRdkPostEffectPipeline::IChannel Class Referenceabstract

#include <RhRdkNewPostEffectPlugIn.h>

Public Member Functions

virtual IChannelClone (void) const =0
 
virtual void Close (void)=0
 
virtual void Commit (void)=0
 
virtual const IRhRdkRenderWindow::IChannelExCPU (void) const =0
 
virtual IRhRdkRenderWindow::IChannelExCPU (void)=0
 
virtual void * EVF (const wchar_t *wsFunc, void *pvData)=0
 
virtual const IRhRdkRenderWindow::IGPUChannelGPU (void) const =0
 
virtual IRhRdkRenderWindow::IGPUChannelGPU (void)=0
 
virtual UUID Id (void) const =0
 
virtual unsigned int PixelSize (void) const =0
 

Protected Member Functions

virtual ~IChannel ()
 

Constructor & Destructor Documentation

◆ ~IChannel()

virtual IRhRdkPostEffectPipeline::IChannel::~IChannel ( )
inlineprotectedvirtual

Member Function Documentation

◆ Clone()

virtual IChannel* IRhRdkPostEffectPipeline::IChannel::Clone ( void  ) const
pure virtual

Return a clone of this channel.

◆ Close()

virtual void IRhRdkPostEffectPipeline::IChannel::Close ( void  )
pure virtual

Close the channel. Implemented as

delete this;

◆ Commit()

virtual void IRhRdkPostEffectPipeline::IChannel::Commit ( void  )
pure virtual

Commit changes to the channel so that those changes can be used by subsequent post effects in the chain. Only valid for channels that were obtained by calling GetChannelForWrite(). If the channel has the same id as an existing channel, the existing channel will be replaced by the new one. If the existing channel was created by a previous post effect in the chain, it will be deleted. Changes to channels that are not commited simply get ignored.

Note
This call merely sets a flag. The process is deferred until after the post effect has finished executing.

◆ CPU() [1/2]

virtual const IRhRdkRenderWindow::IChannelEx* IRhRdkPostEffectPipeline::IChannel::CPU ( void  ) const
pure virtual

Return an interface to this channel for doing read-only operations on the channel using the CPU.

◆ CPU() [2/2]

virtual IRhRdkRenderWindow::IChannelEx* IRhRdkPostEffectPipeline::IChannel::CPU ( void  )
pure virtual

Return an interface to this channel for doing read/write operations on the channel using the CPU.

◆ EVF()

virtual void* IRhRdkPostEffectPipeline::IChannel::EVF ( const wchar_t *  wsFunc,
void *  pvData 
)
pure virtual

Emergency virtual function for future expansion.

◆ GPU() [1/2]

virtual const IRhRdkRenderWindow::IGPUChannel* IRhRdkPostEffectPipeline::IChannel::GPU ( void  ) const
pure virtual

Return an interface to this channel for doing read-only operations on the channel using the GPU.

◆ GPU() [2/2]

virtual IRhRdkRenderWindow::IGPUChannel* IRhRdkPostEffectPipeline::IChannel::GPU ( void  )
pure virtual

Return an interface to this channel for doing read/write operations on the channel using the GPU.

◆ Id()

virtual UUID IRhRdkPostEffectPipeline::IChannel::Id ( void  ) const
pure virtual

Return the channel id which indicates what type of data is used in this channel.

◆ PixelSize()

virtual unsigned int IRhRdkPostEffectPipeline::IChannel::PixelSize ( void  ) const
pure virtual

Return the pixel size in bytes for this channel.