Rhino C++ API  8.6
Public Member Functions | List of all members
ITabbedDockBarEventWatcher Class Referenceabstract

Extension interface for forwarding tabbed dockbar events. More...

#include <RhinoSdkDialog.h>

Inheritance diagram for ITabbedDockBarEventWatcher:
IDockBarEventWatcher CRhinoTabbedDockBarDialog

Public Member Functions

virtual ~ITabbedDockBarEventWatcher ()
 
virtual void OnShowTab (const class CRhinoUiPanel &panel, bool bShowTab, const ON_UUID &uuidDockBar)=0
 
- Public Member Functions inherited from IDockBarEventWatcher
virtual ~IDockBarEventWatcher ()
 
virtual void OnDockBarPositionChanged (DWORD dwNewLocation)=0
 
virtual bool OnDockContextStartDrag (bool bStart)=0
 
virtual void OnShowDockBar (ShowEventArgs args)=0
 
virtual void OnStartTracking (bool bDoneTracking)=0
 
virtual void OnToggleDocking (bool bStart)=0
 

Additional Inherited Members

- Public Types inherited from IDockBarEventWatcher
enum  ShowEventArgs : int { ShowEventArgs::Show, ShowEventArgs::Hide, ShowEventArgs::HideOnDeactivate, ShowEventArgs::ShowOnDeactivate }
 OnShowDockbar event type More...
 

Detailed Description

Extension interface for forwarding tabbed dockbar events.

Constructor & Destructor Documentation

◆ ~ITabbedDockBarEventWatcher()

virtual ITabbedDockBarEventWatcher::~ITabbedDockBarEventWatcher ( )
inlinevirtual

Member Function Documentation

◆ OnShowTab()

virtual void ITabbedDockBarEventWatcher::OnShowTab ( const class CRhinoUiPanel panel,
bool  bShowTab,
const ON_UUID uuidDockBar 
)
pure virtual

Implemented in CRhinoTabbedDockBarDialog.