Rhino C++ API
8.13
|
#include <opennurbs_dimensionstyle.h>
Public Types | |
enum | arrow_type : unsigned int { arrow_type::None = 0, arrow_type::UserBlock = 1, arrow_type::SolidTriangle = 2, arrow_type::Dot = 3, arrow_type::Tick = 4, arrow_type::ShortTriangle = 5, arrow_type::OpenArrow = 6, arrow_type::Rectangle = 7, arrow_type::LongTriangle = 8, arrow_type::LongerTriangle = 9 } |
Defines enumerated values for arrowhead shapes. More... | |
Public Member Functions | |
ON_Arrowhead ()=default | |
ON_Arrowhead (const ON_Arrowhead &)=default | |
~ON_Arrowhead ()=default | |
ON_UUID | ArrowBlockId () const |
arrow_type | ArrowheadType () const |
bool | operator!= (const ON_Arrowhead &other) const |
ON_Arrowhead & | operator= (const ON_Arrowhead &)=default |
bool | operator== (const ON_Arrowhead &other) const |
void | SetArrowBlockId (ON_UUID id) |
void | SetArrowheadType (arrow_type type) |
Static Public Member Functions | |
static ON_Arrowhead::arrow_type | ArrowTypeFromUnsigned (unsigned int type_as_unsigned) |
static ON_Arrowhead::arrow_type | DefaultArrowType () |
static bool | GetArrowheadBoundingBox (ON_Arrowhead::arrow_type arrow_type, ON_UUID arrow_block_id, ON_Xform xform, ON_BoundingBox &bbox, bool grow) |
static ON__UINT32 | GetPoints (arrow_type type, const double *&points) |
static ON__UINT32 | GetPoints (arrow_type type, ON_2dPointArray &points) |
Copyright (c) 1993-2022 Robert McNeel & Associates. All rights reserved. OpenNURBS, Rhinoceros, and Rhino3D are registered trademarks of Robert McNeel & Associates.
THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT EXPRESS OR IMPLIED WARRANTY. ALL IMPLIED WARRANTIES OF FITNESS FOR ANY PARTICULAR PURPOSE AND OF MERCHANTABILITY ARE HEREBY DISCLAIMED.
For complete openNURBS copyright information see http://www.opennurbs.org.
|
strong |
|
default |
|
default |
|
default |
ON_UUID ON_Arrowhead::ArrowBlockId | ( | ) | const |
arrow_type ON_Arrowhead::ArrowheadType | ( | ) | const |
|
static |
|
static |
|
static |
|
static |
|
static |
bool ON_Arrowhead::operator!= | ( | const ON_Arrowhead & | other | ) | const |
|
default |
bool ON_Arrowhead::operator== | ( | const ON_Arrowhead & | other | ) | const |
void ON_Arrowhead::SetArrowBlockId | ( | ON_UUID | id | ) |
void ON_Arrowhead::SetArrowheadType | ( | arrow_type | type | ) |