Rhino C++ API  8.6
Public Member Functions | List of all members
ON_MeshModifiers Class Referencefinal

#include <opennurbs_mesh_modifiers.h>

Public Member Functions

 ON_MeshModifiers ()
 
 ON_MeshModifiers (const ON_MeshModifiers &)=delete
 
 ~ON_MeshModifiers ()
 
ON_CurvePipingCurvePiping (bool allow_creation=false)
 
ON_DisplacementDisplacement (bool allow_creation=false)
 
ON_EdgeSofteningEdgeSoftening (bool allow_creation=false)
 
void LoadFromXML (const ON_XMLRootNode &)
 < For internal use only. More...
 
bool operator!= (const ON_MeshModifiers &) const =delete
 
const ON_MeshModifiersoperator= (const ON_MeshModifiers &mm)
 
bool operator== (const ON_MeshModifiers &) const =delete
 
ON_ShutLiningShutLining (bool allow_creation=false)
 
ON_ThickeningThickening (bool allow_creation=false)
 

Constructor & Destructor Documentation

◆ ON_MeshModifiers() [1/2]

ON_MeshModifiers::ON_MeshModifiers ( )

◆ ON_MeshModifiers() [2/2]

ON_MeshModifiers::ON_MeshModifiers ( const ON_MeshModifiers )
delete

◆ ~ON_MeshModifiers()

ON_MeshModifiers::~ON_MeshModifiers ( )

Member Function Documentation

◆ CurvePiping()

ON_CurvePiping* ON_MeshModifiers::CurvePiping ( bool  allow_creation = false)

Get an object that provides access to curve piping information. If there is no curve piping information and 'allow_creation' is false, the method returns null. If there is no curve piping information and 'allow_creation' is true, a default curve piping object is created.

◆ Displacement()

ON_Displacement* ON_MeshModifiers::Displacement ( bool  allow_creation = false)

Get an object that provides access to displacement information. If there is no displacement information and 'allow_creation' is false, the method returns null. If there is no displacement information and 'allow_creation' is true, a default displacement object is created.

◆ EdgeSoftening()

ON_EdgeSoftening* ON_MeshModifiers::EdgeSoftening ( bool  allow_creation = false)

Get an object that provides access to edge softening information. If there is no edge softening information and 'allow_creation' is false, the method returns null. If there is no edge softening information and 'allow_creation' is true, a default edge softening object is created.

◆ LoadFromXML()

void ON_MeshModifiers::LoadFromXML ( const ON_XMLRootNode )

< For internal use only.

◆ operator!=()

bool ON_MeshModifiers::operator!= ( const ON_MeshModifiers ) const
delete

◆ operator=()

const ON_MeshModifiers& ON_MeshModifiers::operator= ( const ON_MeshModifiers mm)

◆ operator==()

bool ON_MeshModifiers::operator== ( const ON_MeshModifiers ) const
delete

◆ ShutLining()

ON_ShutLining* ON_MeshModifiers::ShutLining ( bool  allow_creation = false)

Get an object that provides access to shut-lining information. If there is no shut-lining information and 'allow_creation' is false, the method returns null. If there is no shut-lining information and 'allow_creation' is true, a default shut-lining object is created.

◆ Thickening()

ON_Thickening* ON_MeshModifiers::Thickening ( bool  allow_creation = false)

Get an object that provides access to thickening information. If there is no thickening information and 'allow_creation' is false, the method returns null. If there is no thickening information and 'allow_creation' is true, a default thickening object is created.