Rhino C++ API  8.6
Public Member Functions | List of all members
ON_XMLRootNode Class Reference

#include <opennurbs_xml.h>

Inheritance diagram for ON_XMLRootNode:
ON_XMLNode

Public Member Functions

 ON_XMLRootNode ()
 
 ON_XMLRootNode (const ON_XMLNode &node)
 
 ON_XMLRootNode (const ON_XMLRootNode &root)
 
virtual ~ON_XMLRootNode ()
 
virtual void Clear (void) override
 Removes and deletes all child nodes and properties, and clears the tag name. More...
 
virtual const ON_XMLRootNodeNodeForRead (void) const
 
virtual ON_XMLRootNodeNodeForWrite (void)
 
const ON_XMLRootNodeoperator= (const ON_XMLNode &node)
 
const ON_XMLRootNodeoperator= (const ON_XMLRootNode &root)
 
virtual bool ReadFromFile (const wchar_t *path, bool warnings_as_errors=false, bool validate_tags=true)
 
virtual bool WriteToFile (const wchar_t *path, bool include_formatting=true, bool utf8=false, bool sorted_properties=false) const
 
- Public Member Functions inherited from ON_XMLNode
 ON_XMLNode (const ON_XMLNode &)
 
 ON_XMLNode (const wchar_t *name)
 Always creates empty default property. More...
 
 ON_XMLNode (ON_XMLNode &&) noexcept=delete
 
virtual ~ON_XMLNode ()
 
virtual ON_XMLNodeAttachChildNode (ON_XMLNode *node)
 
virtual ON_XMLPropertyAttachProperty (ON_XMLProperty *prop)
 
virtual int ChildCount (void) const
 
virtual ON_XMLNodeCreateNodeAtPath (const wchar_t *path)
 
virtual ON__UINT32 DataCRC (ON__UINT32 current_remainder, bool recursive) const
 
virtual ON_XMLNodeDetachChild (ON_XMLNode &child)
 
virtual ON_XMLNodeFirstChild (void) const
 Get the first child of this node or null if none. More...
 
virtual ChildIterator GetChildIterator (void) const
 
virtual ON_XMLPropertyGetDefaultProperty (void) const
 
virtual ON_XMLNodeGetNamedChild (const wchar_t *name) const
 Use this when you are looking for a node that is only one child below - non-recursive, but fast. More...
 
virtual ON_XMLPropertyGetNamedProperty (const wchar_t *name) const
 
virtual int GetNestedDepth (void) const
 
virtual ON_XMLNodeGetNodeAtPath (const wchar_t *path) const
 
virtual ON_wString GetPathFromRoot (void) const
 Returns the full path to this node. More...
 
virtual PropertyIterator GetPropertyIterator (bool alphabetized=false) const
 
virtual void * LastReadBufferPointer (void) const
 
virtual bool MergeFrom (const ON_XMLNode &src)
 src node must have the same name More...
 
virtual void MoveAfter (ON_XMLNode &other)
 Moves this node after another node. More...
 
virtual void MoveBefore (ON_XMLNode &other)
 Moves this node before another node. More...
 
virtual ON_XMLNodeNextSibling (void) const
 Get the next sibling of this node or null if none. More...
 
virtual void OnNodeReadFromStream (const ON_XMLNode *node) const
 This function is called on the top-most node during the reading process. More...
 
 operator ON_wString () const
 
bool operator!= (const ON_XMLNode &) const
 
const ON_XMLNodeoperator= (const ON_XMLNode &)
 
bool operator== (const ON_XMLNode &) const
 
virtual ON_XMLNodeParent (void) const
 Get the parent of this node or null if none. More...
 
virtual ON_XMLNodePrevSibling (void) const
 Get the previous sibling of this node or null if none. More...
 
virtual int PropertyCount (void) const
 < Utilities. More...
 
virtual ON__UINT32 ReadFromStream (const wchar_t *buf, bool warnings_as_errors=false, bool validate_tags=true)
 
virtual bool RecurseChildren (ON_XMLRecurseChildrenCallback callback, void *data) const
 
virtual void Remove (void)
 Removes and deletes this node. More...
 
virtual void RemoveAllChildren (void)
 Removes and deletes all child nodes. More...
 
virtual void RemoveAllProperties (void)
 Removes and deletes all properties and adds an empty default property. More...
 
virtual bool RemoveChild (ON_XMLNode *child)
 
virtual bool RemoveProperty (const wchar_t *prop_name)
 
virtual void SetInternalDebuggingFlags (ON__UINT64)
 For internal use only. More...
 
virtual ON_XMLPropertySetProperty (const ON_XMLProperty &prop)
 
virtual void SetTagName (const wchar_t *name)
 
virtual ON_wString String (bool include_formatting=true, bool force_long_format=false, bool sorted_props=false) const
 
virtual const ON_wStringTagName (void) const
 
virtual const ON_XMLNodeTopLevel (void) const
 Get the top-level parent of this node. More...
 
virtual CharacterCounts WriteChildrenToStream (wchar_t *stream, ON__UINT32 max_chars, bool include_formatting=true, bool force_long_format=false, bool sorted_props=false) const
 
virtual CharacterCounts WriteFooterToStream (wchar_t *stream, ON__UINT32 max_chars, bool include_formatting=true, bool force_long_format=false) const
 
virtual CharacterCounts WriteHeaderToStream (wchar_t *stream, ON__UINT32 max_chars, bool include_formatting=true, bool force_long_format=false, bool sorted_props=false) const
 
virtual bool WriteToSegmentedStream (ON_XMLSegmentedStream &stream, bool include_formatting=true, bool force_long_format=false, bool sorted_props=false) const
 
virtual ON__UINT32 WriteToStream (wchar_t *stream, ON__UINT32 max_chars, bool include_formatting=true, bool force_long_format=false, bool sorted_props=false) const
 
virtual CharacterCounts WriteToStreamEx (wchar_t *stream, ON__UINT32 max_chars, bool include_formatting=true, bool force_long_format=false, bool sorted_props=false) const
 

Additional Inherited Members

- Static Public Member Functions inherited from ON_XMLNode
static bool AutoTypePropValue (void)
 
static ON_wString GetNameFromTag (const wchar_t *tag)
 
static bool IsValidXMLName (const wchar_t *name)
 
static bool IsValidXMLNameWithDebugging (const wchar_t *name)
 
static void SetAutoTypePropValue (bool b=true)
 
- Static Public Attributes inherited from ON_XMLNode
static constexpr ON__UINT32 ReadError = 0xFFFFFFFF
 < Serialization. More...
 
- Protected Member Functions inherited from ON_XMLNode
virtual void * EVF (const wchar_t *func, void *data)
 Emergency virtual function for future expansion. More...
 

Constructor & Destructor Documentation

◆ ON_XMLRootNode() [1/3]

ON_XMLRootNode::ON_XMLRootNode ( )

◆ ON_XMLRootNode() [2/3]

ON_XMLRootNode::ON_XMLRootNode ( const ON_XMLNode node)

◆ ON_XMLRootNode() [3/3]

ON_XMLRootNode::ON_XMLRootNode ( const ON_XMLRootNode root)

◆ ~ON_XMLRootNode()

virtual ON_XMLRootNode::~ON_XMLRootNode ( )
virtual

Member Function Documentation

◆ Clear()

virtual void ON_XMLRootNode::Clear ( void  )
overridevirtual

Removes and deletes all child nodes and properties, and clears the tag name.

Reimplemented from ON_XMLNode.

◆ NodeForRead()

virtual const ON_XMLRootNode& ON_XMLRootNode::NodeForRead ( void  ) const
virtual

◆ NodeForWrite()

virtual ON_XMLRootNode& ON_XMLRootNode::NodeForWrite ( void  )
virtual

◆ operator=() [1/2]

const ON_XMLRootNode& ON_XMLRootNode::operator= ( const ON_XMLNode node)

◆ operator=() [2/2]

const ON_XMLRootNode& ON_XMLRootNode::operator= ( const ON_XMLRootNode root)

◆ ReadFromFile()

virtual bool ON_XMLRootNode::ReadFromFile ( const wchar_t *  path,
bool  warnings_as_errors = false,
bool  validate_tags = true 
)
virtual

◆ WriteToFile()

virtual bool ON_XMLRootNode::WriteToFile ( const wchar_t *  path,
bool  include_formatting = true,
bool  utf8 = false,
bool  sorted_properties = false 
) const
virtual