Click or drag to resize

GH_InstanceDescriptionWrite Method

Default serialization. Only stores Name, NickName, Description and InstanceGuid fields. If you want to store additional fields use WriteFull() instead.

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public virtual bool Write(
	GH_IWriter writer
)

Parameters

writer
Type: GH_IO.SerializationGH_IWriter
Object to serialize with.

Return Value

Type: Boolean
Always True.

Implements

GH_ISerializableWrite(GH_IWriter)
See Also