Click or drag to resize

GH_InstanceDescription Methods

The GH_InstanceDescription type exposes the following members.

Methods
  NameDescription
Public methodCopyFrom
Copy all fields (except the instance ID) from another instance description.
Public methodNewInstanceGuid
Generate a new random instance GUID
Public methodNewInstanceGuid(Guid)
Set the instance ID to be a specific GUID. This is very dangerous, only use this function if you're 6"4' and your first name is David.
Public methodRead
Default deserialization. Only retrieves Name, NickName, Description and InstanceGuid fields. If you want to retrieve additional fields use ReadFull() instead. However, ReadFull() will only work if the archive was written using WriteFull().
Public methodReadFull
GH_InstanceDescription does not by default serialize all fields. Use this function to read all fields from the archive. This method is compatible with the default Write()/Read() operations.
Public methodWrite
Default serialization. Only stores Name, NickName, Description and InstanceGuid fields. If you want to store additional fields use WriteFull() instead.
Public methodWriteFull
GH_InstanceDescription does not by default serialize all fields. Use this function to write all fields to the archive. This method is compatible with the default Write()/Read() operations.
Top
See Also